Problems with Motion Alerts - Spotlit Cam - Solar - iOS - Apple.


I had contacted Ring Support in chat on Tuesday 24/09/2019 as since the last update on the app, I am finding my “Motion Alert” [on/off] switch on the app on my Spotlight Cam is refusing to stay in the “[ON]” position. It has been fine up until the last app update.
My Ring 2 doorbell is fine and there are no problems with the Motion Alert settings there.

What happens is:

  1. Set Motion Alerts to “[ON]”
  2. Set up the “Zones” then save.
  3. Motion Alerts slide switch sets it back to [OFF]

If you try and slide to ON it goes across, then after 1-2 seconds, its displays the spinining dashes/wheel on the app, then goes back to [OFF].
Due to this I am not getting any Motion Alerts even though the “Zones” are setup.

This is happening on the iOS Apple Iphone 8.

I spoke to a customer agent in Webchat, and they called the tech team, they finally reported back to the agent it as “problematic” and they couldnt set to [ON] either from their side when they tried to change it.

With the help of the customer support agent, we have tried to reset the Network Settings, and delete the app, reboot the phone and then install the app again, but these have not worked.
The only final thing not tried is to reboot the camera itself, but since the tech team have reported its “problematic”, it makes me think its an app issue. As yet not heard back from them.

Notes have been made on my account, and I was advised they would email me or call me back.

Is anyone else experiencing this?

its only happening to me on the Spotlight Cam (Solar)
All other features on the camera are fine (i.e. Live View, Zones etc…)


I think I have managed to resolve this, I was advised by the support agent not to reboot my camera but it was the only step left that I hadn’t tried. When I got home this evening it was still light and I deleted the camera from my app and then reset it up from scratch. The one thing I noticed was that when I was asked for the location I only had a choice of ‘garden’ for the rear of my property when I originally set the camera up it was ‘backyard’

I’m not sure if this was related to it but it seems a bit strange however I have tried switching the motion alerts on and off and testing it and it seems to be working fine for now, I would still be interested to know if anyone else has experienced this issue.

Hey @ChrisK ! Thank you for sharing your experience and for keeping us updated on your solution. Happy to see it is resolved and I appreciate your patience throughout the troubleshooting process. I’ll be sharing this information in detail with our apps team so they can investigate further.

1 Like

Thank you for your patience @ChrisK. It looks like a recent app update featured a name change from “backyard” to “garden”, for UK neighbors. Hopefully your prior motion toggle concern has remained resolved! Thank you for being the best part of the Community :slightly_smiling_face:

I have a new Spotlight Cam with exactly the same problem. The Motion Alert switch won’t stay on. I was on the phone with support last night for 1 hour. We tried everything, including deleting the app from the phone, and resetting the cam. Nothing worked. We also selected a different device name, I originally had a custom name “Rear Deck”, after resetting I selected “Backyard”.

I can retuturn it and get another one, but is it the device, phone app, or firmware?

I have an iPhone X, iPhone 6S, and newer iPad, all with IOS 13.1.1. I’m wondering if the new IOS 13.1.1 has anything to do with it?

I am also using iOS 13 beta mode.
My motion switch only started playing up when the latest update for the app came through as part of the Apple iOS updates.
I had tried everything including deleting the app, and reinstalling it, the technical team had even tried to change it and failed. When I asked if I should reboot the camera I was told not to at the moment. That evening however I was a bit fed up by the fact that this had not been resolved so took the initiative to Delete the camera from the app, reboot the camera and add it as a new device. When I tried to add the location I was surprised to see that I was given garden as a location and not backyard which is what it was originally set up as.
It has been fine since I did this and It’s now been 4 days. (I added it back on the evening of Wednesday 25th)
It might be the fact that when you try and turn on the motion switch it tries to communicate with the camera and somehow the location is part of the code and it can’t communicate, so pushes the switch back.

I would suggest you delete the camera from the app, not the app itself. Next reboot the camera and add it back in as a new device.

Thanks, I deleted the device and added new, this time I selected “Side” instead of “Backyard” (I don’t have a “Garden” option). It took and the “Motion Alerts” option is On! I then changed the name to “Deck” and it still works! So, it appears to not like the “Backyard” selection.

Thanks for your help, hopefully Ring support sees this and takes action for a fix and update.

As a side not, I have an iPod with version 12.xx IOS and that didn’t matter.


Hi Tom

I think its more related to individuals accounts, when you register the device/add it, it is stored on your ring account, so deleting the app and reinstalling it wont resolve it as its still on your account with a different location name so therefore the problem still exists.

Once you delete the device, it is then removed from your account on all apps/installs so when you add it again it is a new device and a brand new install, so all the settings (Defaults) are new. I think the problem occured with the name of the location changed on the app to what I had on my account.

So when I tried to switch on Motion Alerts, my app was trying to pass Garden in the app , code, but my account on their servers had it as Backyard, so it was failing to toggle the setting.


Hi Chris,

Thanks for the reply. The strange thing is, support had me hold the reset button in for maybe 20 seconds to reset the device, delete it from the app, delete the app, and start from scratch.

When we picked “Backyard”, we couldn’t set the motion alert switch, it would spring back to off. When we selected “side” it works! I then could rename it anything I wanted. It’s working now so I’m going to leave it.

Thanks for your help,


Will there be an update from Ring to fix this rather than having to delete and re-add? Thanks. All of your replies have helped a lot. I have been so frustrated with this!!!

Ring says an app update has been released that addresses the proplem. An updated app has indeed been released. Mine is working so not going to delete it and try again. They say it’s fixed.

I deleted the device and then added it again. I didn’t have to change the name. I left it backyard. I only had a choice of the ones I already had on line or Custom. Now I can turn on the Motion Alert button. I’d still like to know if there will be an update to fix this more easily. I have another one I need to reset, but cannot reach it. Have a Friend coming over to help. Thanks!!

Thanks, Tom!! The new release didn’t fixe either of mine, but I think I have it under control now. I appreciate the reply!!

Hi @Fred @ChrisK @tom899 can you please confirm this is happening to on your Spotlight Cam: Battery as the title states? We are sending this information over to the team and want to verify that this is all on the same device. Also, are all of your devices connected to Solar?

My device is battery. I deleted each camera and then I added each devise again. I named them the same as the had been previously — backyard and side. After adding them again the motion alert button would remain on. Prior to deleting/re-adding the broom would not toggle on and I was not receiving motion notifications. Thank You for your follow-up!!

Since the update to change the solar spot light went from Backyard (for me) to now Garden.

The update downloaded but then the Motion Slide switch in the app refused to stay in the on position, I called support and they couldnt get it to slide over even when accessing my account. They raised a ticket and notes were put on my file, I was told I would be contacted but 24hr later, nothing back so deleted the device from the app, rebooted camera then added device back, when it asked for location, I was suprised to see Backyard was not avail as location, whereas it had been before. Now I had Garden, when I used that, the motion slide switched worked fine and it now all works normally.

1 Like

My device is battery spotlight cam, No solar. It is working fine now. I picked “Side”, and then custom renamed it “Deck”.

Thank you all for the update. This information will be sent to the team. Please continue to keep us updated with any findings!