Problems with Activating Spotlight Cams

I have several Spotlight cams and within the past 48 Hours there have been issues with activating a live view and the recordings that are shown are usually just black. I use Xfinity high speed Internet, but if I try to view using my cell service the camera live view seems to work most of the time. So it seems to be an Xfinity connectivity issue. My speed tests all show very good speed and I am not having issues with anything other than my Ring devices. All the devices are connected to the WiFi and are in the ‘green’. Any ideas as to how to correct this issue? I am sure if I contact Xfinity they will claim it’s a Ring issue and Ring will call it a Xfinity issue.

I have done All troubleshooting I can do i.e. rebooting router, modem, and have even uninstalled and reinstalled a couple of the Ring devices with no luck.

Thanks for any advice.

1 Like

Can confirm same issues. And worked when activating via mobile. Get your Dev team on this.

1 Like

Spoke with Xfinity this evening and my connection seems to be working very well as far as they can see. This is becoming very frustrating, with cameras and batteries I have well over a $1000.00 in Ring products and they are becoming useless due to the inability to use them. Unfortunately it’s a matter of starting from scratch with a different product and spending another $1000+ for a different system!

There is obviously a connection issue due to the fact that not only can you not activate the cameras but the videos are blank when recording.

I’m having the same issue

Hey neighbors! Video connection concerns are often related to wifi, mobile device, or Ring app communication variables. Excellent work checking with your internet service provider! I recommend also checking your wifi signal strength, or RSSI, which can be found in the Device Health section of your Ring app. Check out our Community post about RSSI for tips on optimizing this signal strength.

Removing and reinstalling the Ring app is a quick way to ensure it is up to date and optimally integrated with your mobile device. On your mobile device, try testing video on wifi only, and then on data only, to see if either connection is more efficient. Please also ensure bluetooth and VPN is disabled.

As some neighbors have mentioned using xfinity service here, we’ve seen other neighbors mention checking router settings as well as account settings in the past. Depending on service and equipment used, xfinity allows for a public hotspot to be enabled on your network. Try disabling this to see if this might help to dedicate resources to your home network. Here is also our help center article on ports and protocols used by Ring devices on a network. I hope this helps! :slight_smile: