Problem resetting Doorbell

Need to reset my Ring Video Doorbell and reconnect to a different WiFi network.

Have Deleted the device from my account via the app, but when I re-scan the MAC Id during setup it tells me the device is still registered to the original owner.

Hey @AndrewShaw. Since this is saying that there is already a registered owner, you may have not fully deleted the device from your account. No worries, our support team can help with this. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Hi Chelsea,

Thank you for replying.

I will try contacting support as you suggested.

I will need to try to find an email/chat solution though as I have difficulties with my voice at the moment due to Cancer treatment.

Phone support isn’t always the best answer for all of us !

Also I am in Australia so will need to see if there is local support.



Also, I’m a little confused as to how I could have “not completely deleted the device”.

I used your Ring app to delete it. Is there another step I need to perform that isn’t documented anywhere?

@AndrewShaw I completely understand and I apologize that our support is very limited at this time! We do not have chat at this time, nor an email to contact unless it is for one of our different languages, as we offer French, Dutch and German email support only at this time. I’m happy to see if I can get this escalated for you to make this an easy process. Do you mind if I email you from the email address you have on file on your Community account so I can follow up with you on this concern? Happy to help further with this! In regards to the deletion, it seems it may have not accepted the removal of the device, as you would only get this message if it was not removed successfully previously. To completely remove a device, you will go into the Ring app > Main Menu > Devices > Device in question > Device Settings > General Settings > Remove this Device.

Hi Chelsea,

Thanks again for your response.

Yes please feel free to use the email address you have on file for further follow-up, that would be great.

Meanwhile I will follow your suggestion just to make sure I have the device completely removed from my end.

I do have the app installed on multiple iOS devices here, I assume I only need to do this deletion on one device and not all of them?



@AndrewShaw Perfect, I’ll be happy to do this if you are unable to get it functioning once trying to remove it again on your end. You should only need to do this from one device, so could you go into another app you’re logged into, go into Devices and ensure it is removed for me? Once it is completely removed and no longer visible on all devices (once done on one, should be removed for the others), try to set it up again and let me know how this goes!

1 Like

Hi again Chelsea,

I think I have this figured out now.

What I found that our Ring Video Doorbell was initially registered and set up on my partner’s iPhone. So far I had deleted the doorbell from my iPhone only. Once I checked the device setup on my partner’s phone, it recognised that the doorbell was offline and then allowed us to redo the setup process (which was my initial goal as I am tidying up wifi networks in my house and needed to move the Ring device to a newer wifi network).

So what I didn’t appreciate was simply Deleting the Ring doorbell from the app on my phone did not the disassociate the device from the account and the primary mobile device it was set up on.

Thanks so much for your help here.

Kind regards,


@AndrewShaw Nice job getting that sorted out! My apologises that I didn’t think of that off the bat, as deleting the Doorbell from a shared user account like your’s only deletes your access, but not the Doorbell itself from the account, as it must be done by the owner’s account. So glad you got this sorted out, and I will make sure to keep that in mind for future. Hope you’re staying safe and healthy and I’ll be around if you ever need help with anything else! :slight_smile:

Hi again Chelsea,

I need your help again now !

The Video doorbell is set up and working again fine on my partner’s phone under a unique ring id we created specifically for that device.

As you may recall from last time I had deleted the ring app and login details from my phone. I have now re-added my email address as a shared user, I got the Accept Invite email, which I have accepted, but I still cannot see the device from my phone. The Devices screen only offers me the chance to setup a new device either via re-scanning the QR code or re-doing the setup process which I am pretty sure I shouldn’t need to do.

The doorbell is already setup on our home wifi network and works fine, all I am trying to do is enable monitoring access from my own device so while sitting in my study (not the same room as my partner’s study) I can also access the video feed etc.

I’m sure I’m missing something very basic !

Kind regards,


Hey @AndrewShaw! It sounds like you are looking to add your Ring account as a Shared User. It sounds like you’ve taken all the proper steps and even received the Accept Invite email. As long as the email used is the same email you are using to log into the Ring app on the desired Shared Device, the Doorbell should show up.

It can sometimes take a few moments to do so. Try removing and reinstalling the Ring app on that device if the Doorbell is still not accessible as a Share Used. Please also check locations from the location drop down in the Shared Ring App, as it might be found under a different location. I hope this helps! :slight_smile:

Hi Marley,

Thanks for getting back to me.

Yes, I am trying to set myself up as a Shared user on our account.

I have just deleted and reinstalled the app on my iPad and I am definitely using the same email address. Still no sign of the device.

When I click the “3 lines” menu on the app Home screen, and then the “Devices” entry, the screen I see is just like the 1st screen when you first set up a device, with the option being “Set Up a device”.

I guess as the next step I can delete myself as a Shared user and re-try the add user process if you think that is worthwhile?

Not sure if it is relevant or not, but the account the device is registered under is a different email address to mine that I am trying to add as a Shared user, but my guess is that would be pretty normal. As long as I send the Add request to my email, and accept the request, that should be enough - I would guess!!



1 Like

Appreciate the update @AndrewShaw! You are definitely doing this correctly. As the email is different from the one you used for your owner account, the shared user invite should have no problems. Trying again is certainly worth a shot! Reinstalling the app was a great step, as is trying on another mobile device entirely if possible.

If following the steps to add a shared user does not result in what is explained in this help center article, try using another email just as a test, if possible. This will factor out any email or user account conflict, although there shouldn’t be any in the first place. Remember to accept the invite in your email inbox! As you’ve confirmed checking or attempting most of the above recommendations, our support team might be the next best step for some in depth troubleshooting.

If this concern persists, Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile: