Privacy Zones Problem

I have a Ring Pro 2 Hardwired and can’t set any Privacy Zone in the app.
No +, X or any button apears after I click Add Privacy Zones, the only thing i can do is click the back button.

I have tried doing this from an iPhone and an iPad, but both have the same issue.

Can I get some help with this problem?
Thank you!

Hi @user62846. First, make sure that your Ring app and phones OS is up to date with the latest version. Next, visit this Help Center article here to learn how to add a privacy zone.

Thank you for the reply, but:

  • I have already checked that page and video
  • I have iOS 17.0.3 which is the latest
  • I have Ring app 5.65.1 which is the latest

So none of those are the sollution
Please check again the image above and try to find a sollution.

Thank you!

I want to add two privacy zones to block out my neighbours.My camera is hardwired and we get every motion of them doing anything. When I go to device settings and get two the screen to add the ADD Privacy Zone nothing happens. Help.

Hi neighbors. Thank you for sharing this information. Our team is aware of this issue and is working to fix it as soon as possible. I will be marking this response as a temporary solution so others that come to this thread can easily find my response. Once we have an update regarding this concern, we will post it here. Thank you for your time and patience.

Has this bug been fixed yet? I have a Ring Pro 2 and I can set a privacy zone and save them but they don’t appear in recorded or live views.

Just power cycled my Ring device and all works now :slight_smile:

1 Like

Hi neighbors, this issue was resolved in an app update. If you’re still experiencing this issue, please make sure to update your Ring app to the latest version available from the app store. Should the issue persist after updating the app, please reach out to our support team for further assistance. You can also get in touch with our support team on Facebook @Ring.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.