Plug-In Camera showing 0% batterys

Support is beyond poor. I have tried to raise issues, clear bugs reported here, they don’t care. Nothing gets fixed. I had the pleasure of setting up an outdoor plug-in camera. It rained. Within 24 hours the new camera was thinking it was a battery camera and had 0% remaining. Really? Wow.

Hi @mysteryy. I have moved your reply over to a new topic as the concern you’re describing does not match what the original thread was about. Can you confirm which model of Ring Camera you have? You can find the name of your device on the Device Health page in the Ring app. Have you tried any troubleshooting steps on your Camera yet? I’m happy to help once I have a bit more information on what you’re experiencing, that way I can provide relevant troubleshooting tips. :slight_smile:

So the issue is Ring does not make a watertight electrical connection. It rained, water got in the connection. Camera failed within 24 hours of being put into service. Apparently, users have discovered this on their own and some have found dielectric grease to help as a workaround to the poor product design.

If rain got into the connection then you didn’t firmly plug it in to make the watertight seal.

It was 100% firmly plugged in. Many others complaining of same issue, I read dozens of posts.

@mysteryy If water has gotten inside your Camera and caused any damage, you will need to follow up with our support team so they can review the damage and your device’s warranty to determine the best resolution moving forward.

best resolution is to better design your products.