Permanent Privacy Zone?

Hi there!

I’m new to Ring and have just set up my Ring Pro doorbell. When doing the initial setup, I got ahead of myself and put in a privacy zone before the device went through its charging and update cycle.

Now, I have a privacy zone that I can’t seem to get rid of. I’ve tried doing a reset of the doorbell, but that doesn’t seem to have worked.

Any thoughts? Thanks in advance!

Welcome to the Community, @Rising_Sun_Sailor! No worries at all, I still get excited about using all the great features of the Ring devices upon a new setup myself. This privacy zone can indeed be undone, by following these steps:

  • Open your Ring app.
  • Tap the three-lined menu on the upper left-hand side of the screen to open the side menu.
  • Tap Devices.
  • Select desired device.
  • Tap Device Settings.
  • Tap Privacy Settings.
  • Tap Edit Privacy Zones.

While editing the privacy zone, there should be a trash can (delete icon) to remove a zone. If not pressing the “+” icon should then display the delete option for any existing zones. Feel free to also check out our help center article for more information about privacy zones, in case you want to use the feature. I hope this helps! :slight_smile:

Thanks for the reply!

I tried doing that, and, unfortunately, it didn’t work as I couldn’t even select the old privacy zone for deletion.

That said, I was dual tracking the solution and called the support line (just got off the phone with them). Ultimately, I had to add a new zone, save it, and close the app. Once I did that, it overrode the original privacy zone setting and I was able to remove the new one that I built.

1 Like

My problem is I am missing the “edit” privacy zone button. Any ideas?

I had the same problem today. I left everything alone for an hour and when I went back in the zone had been deleted