Only 1 of 3 Ring device showing up on some signed in iOS devices

I have a Ring Doorbell Pro 2 with Chime, and 2 Floodlight Plus cameras, both bought in the last 3 months. On the first phone they were set up with (mine), all 3+1 devices show up, as they do on
However, signed into the same account, with the same email address on 2 other phones in the house including my wife’s, only the doorbell and chime appear. I’ve signed out, and back in again, changing the password in between to be sure, and still nothing.
All 3 are Apple iPhones (8, X and 11 respectively).
I have a Ring Protect subscription covering all 3 devices.
Could it be possible that I have to climb out to the roof of my house and press the pair button on the two cameras to show them on the other 2 phones?!
I’m guessing the next step is uninstall and reinstall on both other devices, but it seems pretty poor that that might be the answer.

Uninstall, reboot, reinstall worked. Daft but there you go I suppose.

1 Like

Hi @casesensitive. I’m glad to hear you were able to get this resolved. It’s possible the Ring app or OS on one of your other mobile devices may have not been fully updated, as this isn’t typical behavior. However, the basic troubleshooting steps you tried took care of it and you shouldn’t run into this again. :slight_smile: