Ongoing lag upon opening app

I currently have the stick up cam inside my home and a flood light cam outside the house. Both of which are on constant recording. I choose to only get notifications for the outside camera for protection and the inside one is more to keep an eye on pets and kids so no big deal. The inside camera is located literally within 3ft of our router, yet when I’m out of the house and try to connect to it, it takes an extremely long time to connect and is super glitchy. It is so horrible that I can not actually watch out even talk on it. I then choose to switch to the $30 camera I have in the kitchen. The outside camera like I stated is set up to watch for motion along the driveway and front door. It is roughly 15ft from the router inside. So still not too far. When I get notifications that someone or something is in the area and I click to see it, it will load for minutes sometimes until I get so irritated I force close it, go back in and by then whatever was there is now gone. This is so frustrating. I bought this to protect my house yet I can not do this cause it will not load correctly. Even when I open the app it will say at the top “well this is taking a long time”. Our WiFi is set up to automatically put things in as it needs either at 2.4ghz or 5ghz, we have pods as well and everytime I test it, it says it’s running fine with no issues. Even when I’m sitting in my very living room these issues happen. When away from the house I have been both, on WiFi and only on mobile data at 5G and still issues. Has anyone had these issues and know how to fix this? I feel frustrated and taken for with the money we put into these systems that don’t work properly and we have to do all the tweeking. Any help is appreciated. Thanks

Jrutherford80 -

Have you tried ensuring that your Ring equipment ONLY uses a 2.4 GHz WiFi band (i.e., that it NEVER switches to using a 5 GHz WiFi band)? If so, what was the result?

1 Like