One of my indoor cameras always offline

I have 3 cameras,only one of it always offline by itself, and I do reconnect will not working, I have to choose “I change my WiFi password “to set it up again, that will work,but around 3-4 hours later , it will offline again, I have to do the”I change my WiFi password “again. The other two working well, only this one will offline 4times a day.

Hey @Feifeiou. Could you remove the Indoor Cam from your Ring app (after saving any videos you need), reset the device by pressing and holding the setup button for 20 seconds, and then setting it up in the Ring app again? From there, monitor the device to ensure it is not falling offline. If it continues to fall offline, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Hi , I did that many times , when I set up again still offline within 1 minutes and will restart itself like 5 minutes later and I need to do everything start over angina, and when it down it will offline in one minute again.

Thank you for attempting those steps, @Feifeiou! As it looks like you’ve covered all of the best steps, and this concern is persists, a more in-depth look at this may be necessary. Our support team will be happy to help further with this. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. Feel free to let us know how this goes! :slight_smile: