Notifications no longer work

Before the last Ring app update for my iphone (early May 2021), I had motion notifications set up on my Ring Doorbell and Ring Spotlight which worked fine.

After the Ring app software update, motion and ring notifications do not work for either device.

I have verified that everything is set up on my iphone and in the Ring app to receive notifications. Wi-Fi connection is good and I have verified that I do not have “Do not Disturb” enabled on my iphone. I have also played around with varying the motion detection frequency and enabled/disabled the “people only mode” and “advanced detection mode” with no luck.

In summary, all of the settings on my iphone and on the Ring app are the same as prior to the Ring app update when notifications worked, but after the new Ring app update, notifications do not work. It does not seem like a coincidence that all of this coincided with a Ring app update.

@lily_belle Is iOS itself set to allow notifications from Ring? Also check that iOS is fully up to date.

1 Like

This same thing happened to me as well and I am unsure why. I have Ring doorbell pro, and with the latest update I am only recording “Person detected” and not “other motion.” I have ensured my motion zone is set appropriately, and “People only mode” is turned off. Prior to the update I would record all motion as my preference, and now all I get is people. Very frustrating.

Yes, notifications are set up for Ring on Iphone. IOS is up to date.

1 Like

I believe it is due to the recent Ring app update. It worked fine before the app update. I have no other issues: motion is detected and recorded just fine.

1 Like

Hi neighbors. Thanks for bringing this to our attention. Since a few of you seem to be having a similar concern, I’m more that happy to pass this information along to our teams here for investigation. If you can please, give me a few more details. What is the phone type, OS and Ring app version? (iPhone XS MAX, IOS 14.4.2, Ring app 5.39). Also, try this with wifi only on/off, to see if this changes. Hopefully, we’ll be able to get this sorted. Thanks, neighbors!

I am having this problem now. iOS 14.7.1, iPhone 12 Pro Max, Ring app v. 5.42.0. Notifications are on. I haven’t changed anything. Seems to have started around the time I updated iOS from 14.7 to 14.7.1.