Notifications coming through but no sound

I installed my Ring 2 yesterday, and whilst the notifications come through to the phone ok, and the phone vibrates, there is no notification sound played. I have tried changing the notification sound but still notifications are silent (apart from the vibration).

All other notifications from other apps on my phone work as expected and play the notification sound fine.

The device is running Android (it’s a Xiaomi Mi 8 Pro), and I have tried removing and reinstalling the app, but still there is no notification sounds

Anyone have any ideas on how to resolve this?

Thanks

Check your app permissions for Ring. Have you also long pressed the notification to make sure it’s set to sound? Just 2 thoughts. It should work. I have many Android phones and running many OS. I don’t have that brand though.

I’ve checked the app permissions itself and it looks to have all it should. There’s no permissions specially relating to sound (I would of thought that it would serve correct permissions on install). Checked the notification by long pressing and all appears ok there too. Worth a try, so thanks for the pointers

I’ll try on another phone when I can find one, so possibly a compatibility issue. A little annoying though.

I’ll take a look into it more later. What Android system are you using now? Also are you in the US or somewhere else.

It’s running MIUI 11, which is Xiaomis build of Android 10.

I’m based in the UK. Thanks for looking into it. Hopefully it’ll be an easy fix

Been testing some more and definately seems a bug and no notification sounds being played. Still strange that the vibration works fine.

How do we report bugs to the Ring team?

Ok… for anyone else who has a Xiaomi phone running MIUI and gets not sounds, I have found a fix.

  • “Hidden Settins for MIUI” app from the Play Store.

  • Open the app and select “Manage Applications” from the Android 9 tab (works fine if using MIUI 11 / Android 10)

  • Find the Ring application from the list and select it

  • Select the Notifcations option

  • Ensure the “Allow Sound” setting is set to ON.

Once this setting is changed, the notification sounds work as expected. Unfortunately the MIUI app settings do not let you see these options, so you need to use the hidden settings app to get to the standard Android app settings.

1 Like

Glad you figured it out. I have that setting available. So, it was the phone’s UI then.

Kind of yeah. I am not sure why the Ring app doesn’t set this permission on install so thats where the problem really lies. Then the Xiaomi customised version of Android restricts you from getting to the setting without a 3rd party app. So both to blame I guess.

Hopefully if anyone else has the same issue they will find this and be able to sort it. Was bugging me for a couple of days.

I have the same problem but with an iPhone. I’ve had 4 conversations with customer service with no help from them. It will send sound about every 10 motions and every 7 rings. So the sound is fine but very inconsistent.

1 Like

Same issue here.

Took your advice, downloaded the MIUI hidden settings app (tried two of them, actually) and that setting (allow sounds) does not appear.

I went to manage apps --> ring --> app notifications and it’s not there.

Any other ideas? I’ve perused all the settings on my phone itself and in the app.

There’s an “Allow notification dot” toggle but no “allow sounds” one.

I have a Moto Z2 running Android 8. Thanks in advance.

Hi,

Unfortunately MIUI is the custom version of Android that Xiaomi use on their devices. Due to this, the app is not going to help on a Motorola device. I am unsure how Motorola customise their OS, so cannot help with where to find the settings, sorry.

It is annoying when phone manufacturers change stuff that should be standard Android features.

I hope you find a solution.

Hello. Did you solve the problem ? I have tur same problem ?

Hi,

I solved the problem in the case of using MIUI on Xiaomi devices but anable to advise further regarding any other device

OK my sound always worked until about 2 weeks ago. I get a visual notification but no sound. I have checked all the settings and everything is set correctly. I even checked the MIUI settings and it is correct. But still no sound notification. I am using a Samsung Galaxy S10.

OK my sound always worked until about 2 weeks ago. I get a visual notification but no sound. I have checked all the settings and everything is set correctly. I even checked the MIUI settings and it is correct. But still no sound notification. I am using a Samsung Galaxy S10.

I used to get notified now dont at all. Struggling to sort this problem