Notification sound change does not save

I had a specific sound ( Halloween sound) as my notification sound. It was removed I assume recently and defaulted to the wind chime. I go to settings to change it and changed it to echo. There is no option to save so I chose echo and then hit back button. I closed app and reopened and it does show echo as the sound I chose but it still alerts with windchime and I hate that sound. Why is it not saving my choice. ? I checked for app update and phone update. Everything is current. Toggled cellular on and off as well

Hi there, @Imtamtastic! It sounds like you are doing everything correctly. The best next step here will be to remove and reinstall the Ring app, as well as ensure there is not a VPN enabled on your mobile device. After you successfully assign an app alert tone, try triggering a few events on your Ring device to ensure this change is communicated and saved. I hope this helps! :slight_smile: