Nothing works

I cannot sign in
I cannot change my password
I cannot verify my account with the code
The customer service number doesn’t work

Same here !

When I was looking for help - Chat suggested but no-one answers. I’m new to Ring and will retunr products for having such rubbish service!

Hugely underhelmed!!

Just installed this morning. Now nothing works. I can’t even log into my app.

Ring is just another sh1tshow electronics company apparently.

My Ring stopped working immediately after SamSung installed an update today. I get message, “having trouble finding location”. Tried everything to fix.


Mine has been installed for about 3 days and this morning had same issue. I had to remove, plug in power USB and go through setup process which updated firmware. Everything worked fine after that

Sorry to hear about this, neighbors! It sounds like this may be related to our recent status found at, or in the Community Announcements. Our team is working on a solution as we speak, and will update the status when this concern has been resolved.

If you are needing further assistance, Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.