Not working properly with S10+ since Android 10 update

I’ve had a Floodlight Cam for just over a year and everything has been working perfectly, other than the occasional need to clear data to get rid of lag.

However, now my Floodlight Cam works perfectly on my Echo Show, but on my Samsung S10+ I can’t hear the person at the door, although they can hear me fine. Both the Show and the S10+ are on the same network (other than when the phone is on 4G obviously). On playback of recordings the audio is perfectly legible on both ends.

I installed the Ring app on an old Samsung S7 Edge, and voila, it worked perfectly, audio hearable at both ends of the connection on live stream. Switch back to the S10+ and problem comes back.

S10+ had an update to Android 10, before which there were no issues with the audio on the S10+, which leads me to believe there is an issue somewhere between the app and Android 10.

I’ve been in contact with Ring support, who asked me some questions which were completely irrelevant, and who told me they escalated it to a specialist team. Haven’t heard anything back for 19 days (and counting) and my emails are now being ignored.

Things that are NOT the problem:

Internet connection: I have 350mbps down, 40mbps up, and in actual fact average speed is around 376mbps down and 42mbps up

Wireless connection: I have a Netgear R8500 and a Netgear EX7500 mesh extender. The EX7500 is designed to mesh with the R8500 using the same SSID. The R8500 is about 30 feet from the floodlight cam, and the EX7500 is about 10 feet from the cam. There is one wall between the cam and the EX7500. The RSSI signal on the S10+ varies between around 43 and 53.

WiFi channel: My router and extender automatically switch to least crowded channel. In any case, I have checked with several WiFi analyzer programmes, on both Android and Windows and there is no appreciable congestion.

My Echo Show connects to the EX7500 and when I stand in exactly the same place as my Echo Show with the Samsung S10+ the problem remains.

I’m really hoping this can be fixed, because right now, unless I want to carry around the Echo Show, or downgrade my phone, the Floodlight Cam is useless for one of it’s main functions for me - which is to be able to answer the door to delivery people etc when I’m at work.

Oh, and also, I have tried RRRing the app:

-Remove the app
-Reboot your phone
-Reinstall the app

Doesn’t make the slightest difference.

UPDATE:

I noticed that with Bluetooth turned off on my phone the Ring Floodlight audio problem went away. So then I started experimenting. Turns out that the problem is not Bluetooth, but the Samsung Watch which is connected with my S10+. If I unpair the Watch from the phone then the Floodlight audio problem goes away, even with Bluetooth still enabled on the phone.

So it looks like the problem is either with the Watch firmware, or there’s an issue between it and the Android 10 update Samsung pushed.

I’ve also seen a ton of posts from people who have S10 phones and various Samsung watches having this issue but the problem with them is getting live video to work. Clearly there’s an issue between the Watch and the S10 phones after the last updates on both in January.

UPDATE 2:

Disabled Timeline feature on Ring app. Now Rapid Ring works fine, and audio is perfect at both ends, even with Samsung Watch connected. However, main Ring app wouldn’t connect to Live View.

Cleared data from main Ring app, reinstalled it, Timeline was automatically enabled. But now the audio issue is gone, with both main and Rapid Ring apps, with Bluetooth on and Samsung Watch connected.

Hopefully that situation lasts. Main Ring app is still too many clicks to actually answer the door, but Rapid Ring app still uses default text sounds rather than Ring alerts.

Thank you for sharing your experience in detail @Cod! Excellent work going through all those steps to find a solution. Removing and reinstalling the Ring app is a great way to ensure it is up to date and optimally integrated with your mobile device. When using the Ring app on Android, I recommend checking for any Android apps the might conflict with the Ring app. Also, remember to disabled any VPNs. I hope this helps! :slight_smile:

Well, it would be nice to come back and say it worked perfectly, but the fact is that the fix didn’t stick and now the only way to get the audio to work properly when answering the door is to disable the Bluetooth link between my Samsung S10+ and my Samsung Watch, and then reenable it once I’ve finished with Ring.

Not the ideal solution, I’m sure you’ll agree. Still not sure if the issue is with Samsung or Ring to be honest, and I’m so fed up at this stage that I’m seriously considering switching security camera brands