Not Charging

Charging Problem Update:

I installed a Ring2 on an existing electro-mechanical doorbell system with a 16 vac transformer. It worked great for over 5 weeks, charge level staying between 98% and 100%. Now the charge goes down 5% per day requiring me to remove the battery pack to charge it. The battery is not being charged internally. Voltage at the transformer is 17.1 volts. Voltage at the Ring2 rear terminals is 17.1 vac. Lack of a voltage drop at the ring terminals means that there is no charge current flowing into the Ring2. The Ring2 is not charging even though there is 17.1 vac at the terminals. I think there must be an internal failure of the charging circuit.

I called the Ring help line (800-656-1918 ). They replaced the Ring2. This did not correct the problem. I even replaced my 16 volt transformer with a 24 volt transformer. I tested voltage and current at the Ring2 terminals. Voltage is at 24 vac, Current flow at the Ring2 terminals is 9 mA.

There are many similar problems posted here on the Forum, A similar post here on the Forum stated that his charging problem occurred after a firmware upgrade. His issue was not temperature related as he lived in Southern Florida.

As mine worked great for the first 5 weeks, And now I have the same problem, even with the new Ring2, and nothing in the enviornment is any different than the first 5 week, I am wondering if this is a firmware problem.

My question to Ring technicians: Do you have a firmware issue causing this problem?


Hey @Juaire! It certainly sounds like you have the proper power supply and wiring for a charge. Please ensure the wiring used is not too thin, as thinner than standard gauge can cause resistance.

Excellent work checking on temperature and environment for contributing factors . Keep in mind, the charge from wiring can also depend on usage, or the number of events. I recommend also checking your wifi signal strength is strong, as a device struggling to communicate events might use more battery to do so. Let us know how this goes! :slight_smile:

Wire that is too small would cause a voltage drop at the Ring. The voltage at the ring is the same as it is at the transformer, 18.1 volts, no voltage drop. If the ring were charging it would cause a voltage drop, no voltage drop means that the ring is drawing any current. A post here on the forum stated that the ring doorbells are programmed to quit charging when the temperature falls below 32F because Lithium batterys are not supposed to be charged below 32F, can you confirm or deny the programming issue. It worked great for the first 5 weeks, charge level holding in the upper 90s%. Something occurred around January 10 to cause it to stop charging. I suspect a firmware update

1 Like

I am in the same situation. None of my wired outdoor devices will currently charge via trickle charge on the ring doorbell 2 nor solar panel charge. Ring has changed the firmware. They were charging before last update. My working theory is ring disabled charging in weather below 32F in order to prevent their batteries from being a fire hazard. Sadly they have not admitted to the community they did this nor have they given us an alternative. I cannot climb a latter to several of my cameras during the winter to pull batteries. This was why I went with Solar charging for those. Ring has screwed us and we need to consider a class action lawsuit.