Not all devices showing on Ring app on Mac OS

Hi,

I have 4 ring cameras (doorbell and 3 floodlights) but on my Mac within Ring app I can only see my video doorbell on the list of all devices. On my iOS I can see all of them. And ideas how to fix it or what might be the issue?

Thanks,

Filip

Hey @filip88. Have you tried deleting the Ring app from your Mac computer and reinstalling it? Give that a try, as well as a computer reboot (off/ on), and double check you are logging in with account owner credentials. If you still do not see your other devices, please ensure there are not multiple locations within your Ring app menu. Let us know how this goes! :slight_smile:

I have the same problem. I just added a new security camera and it is not showing up in the macos app. This is not a corner case and it shouldn’t require me to reinstall the app or reset the universe. Ring would do well to address common use cases and fix annoying bugs in their software.

FWIW, this is my third Ring device and I am slowly heading twoards regretting my decsison.

What’s the problem with having more that one location?

I have a ring device in Portugal as well as 2 in the UK. I can no longer see the Portugal device in the Ring app on my iPhone but can still view through the Ring app on my Mac desktop.

Why has it disappeared from my iPhone app?

Hi @NickA. For your specific concern, I wanted to offer some help so you can locate where the other location is on your Ring app on your phone. If you open up the Ring app on your iPhone and click on the main menu at the top left, you will see a name of one of your locations above Dashboard. Select this, and then tap on your other location. From here, you can toggle between your UK and Portugal locations to see both of your devices. The app on the Mac shows all devices at once, no matter the location, which may be why there were some differences between the two apps for you. Hope this helps!

1 Like

Hi, Thanks for your reply. The problem was solved yesterday by the Ring helpdesk in exactly the way you mentioned. Apparently, the temporary disruption was caused by the recent update to the App which changed the default from seeing all the devices to only see those in a specific location unless you toggle it back to ‘view all’ which I have now done.

Many thanks for taking the time to respond.

1 Like