No temporary wifi during set up mode

Recently the power went out in the house. All the cameras but 1 came back on and are functioning properly. However the 1 that isn’t does not create a temporary wifi network to connect to during the set up mode and therefore I am unable to complete the set up.

I have tried resetting the device.
It had up to date software.
Moved it to literally sitting right next to the router and tried resetting the device and tried the set up again.
Router speeds are not an issue.
It has not been uninstalled and still no temporary wifi signal is created to connect to.

All unsuccessful

How in the world do I fix this or is my device broken.

Hi @user24935. Which specific Ring device is this? Try removing power from the device for 5 minutes, then adding the power back to the device. Also, try using a different device for the setup such as a tablet, or another phone. If you are still unable to get the temporary Ring network to show up, you’ll need to reach out to our support team. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.