No Ring Network. White circle spinning. Tried every suggestion on this forum

First, I’m very frustrated that I’ve had to post this problem for the 3rd time here in the hope of any response/solution. Second, I see this problem is rampant across the boards and there appears to be no solution.

Ring Pro Video Doorbell. Hardwired using the RING transformer kit. Original RING unit was bricked from the box and Ring advisor advice was to return it to Best Buy and buy a second, then return the original unit in the second units box for a refund. SHADY, but I did it. Second unit worked perfectly fine for about 4 months. Then one day it stopped.

Would not connect to network. I’ve tried EVERY possible solution I’ve read here across about 40 posts on the topic.

  • I have NOT changed my network.
    *I have reset my router / wifi connection multiple times.
    *Applied a short reset to the Ring Pro with orange button on side. Dozens of times.
    *30-second hold reset with button on side. 5-6 attempts.
    *Uninstalled & reinstalled APP on phone.
    *Uninstalled & reinstalled app on 2nd phone.
    *Uninstalled and reinstalled app on 3rd phone.
    *Removed the RING device from each phone app THEN uninstalled and re-installed app on each phone. (Galaxy A71, iPhone 8, iPhone 12 FYI.)
    *Unplugged the ring transformer overnight & re-plugged.
    *Did that then uninstalled and reinstalled app on all phones.
    *Oh, and now I tried to link my Rng to my Amazon account only to get the message that my amazon account is already linked to a ring account, but NEITHER Ring NOR Amazon show my account linked to each other.

No matter what state I try to reset the Ring, NO PHONE FINDS THE Ring-xxxx network. It never connects automatically, nor is the Ring-xxxx network visible on any wifi device (all 3 phone, 2 iPads, neighbors phone, NADA. THERE IS NO DARN RING NETWORK BROADCASTING FROM THE RING, but the white circles and circles and every few hours the ring happily chatters at me telling me it is in setup mode and is part of the world largest BLAH BLAH BLAH. The iphones occasionally get a “Trying to connect to Ring-xxxx” then follow up with “Cannot find Ring-xxxxx”. My Samsung doesn’t even get there, it just keeps asking me if the white ring is circling and I say yes.

I see this issue ALL OVER the forums with no resolution.

May I simply get a full refund. Also on my chime because a chime is worthless without a Ring.

Oh - and my Chime - Since I removed all devices on my app and re-installed the app, I needed to setup the chime again, but it tells me when I scan the QR code that the device is already registered to an account… BUT SINCE THE ADVICE WAS TO DELETE ALL DEVICES AND REINSTALL THE APP, there is no Chime visible on my account to “remove the device” so I can then re-setup the device.

Short Version:

Ring Network doesn’t exist.
Ring says my Amazon account is already linked to a ring, but I can’t see where and Amazon says it isn’t.
Chime says it is linked to an account (mine) but won’t let me set it back up, because it is linked to an account (mine) but since my apps were wiped, I have no linked chime on the apps.

AAAARRRGHHH!

Hi @WarOrk. It looks like you’ve gone through all of the basic troubleshooting as well as some more advanced troubleshooting as well. In this instance, I would recommend following up with our support team so they can take a deeper look at this with you and help find a resolution in order to get your Doorbell up and running. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.