No Ring network appears in my Wifi network during setup


I’m so angry. Ring already replaced my device and then they told me i likely need a new transformer. I bought one but we can’t find where the transformer is, and reading on here, it seems that might not even be the problem.
I need to a Ring contractor to come do it for me and make it work.
Meantime, the device yells at me every 20 minutes or so, “Welcome to Ring blah blah blah” setup mode.
I can’t get a break here. An electrician was here and couldn’t find the old transformer to replace. What do i do?

I can’t find it either not can I return and it was so expensive

Mine too! Had it got Christmas. Worked fine. Battery went. 3hours of uninstalling and reinstalling app, switching and inputting router and it will not connect to the home wifi anymore. So fed up

I have 2 Ring doorbell PRO units. I have been trying everything listed in here and more, and neither one will work. I am out over $400+. What a rip off. Where can I go rate this product so that nobody else buys ring products.

SUCCESS! I was stuck at the unable to join Ring network step. After checking just about everything, I thought about the fact that I have an ATT microcell. I disconnected its power source and was then able to connect to the ring network and finish setup.

Had same problem while attempting to setup via iPhone. When I was going to search for help, noticed my iPad was trying to setup.
Shut my phone off and followed prompts on iPad.

Check that another device is not trying to login to that WiFi.

Same story for me. Two doorbell pros - originally setup - then almost immediately had connection issues. Customer support sent me a transformer I installed (the one I had was 16V so fairly certain that was nonsense). I checked all the wiring and voltage is good - but neither will broadcast a Wi-Fi network. Tried different devices (iPhone, iPad) - reinstalled the app - obviously did the hard reset and disconnected power and wiring about 100 times. Bottom line is they just are not broadcasting Wi-Fi any longer. So now what? I don’t really care about the money - my next step as the engineer I am is to smash both of them with a sledgehammer - I will make sure to upload the video to YouTube for everyone on this thread :slight_smile:

1 Like

I figured out how to resolve mine. Took the face plate off again, press & hold the button on the side of the device for 20 seconds and the setup wizard started talking me through it from the doorbell within about 30 seconds after releasing the button. Hope this helps someone else!

1 Like

I bought a Ring Pro and I followed the app instructions and could never get it set up . . . got the dreaded “can’t join network” message. After an entire afternoon of trying to set op my Ring Doorbell Pro with no luck, it went into the trash. What ridiculous piece of junk! DO NOT BUY a Ring Product.

1 Like

I really am sick to death of Ring products. Ring 2 doorbell is 3 feet away from the chime pro which is 10 feet away from my router. By the time i get the notification the person has given up and left. They gave me a new replacement but its hopeless.

I was originally happy with my floodlight cam. Wired to the mains, great control to set the motion zones. Now that is going wrong and not detecting anything. I uninstalled everything and the app. Now trying to reinstall but cannot find the ring network. I can connect to the chime pro but not my home network. The camera is 4 feet from the router and the chime pro is too far away and i get bad signal . Just in a loop of searching i watched video tutorials but they don’t help. This company is useless. This is the last straw for me. I should have installed a decent wired security system in the first place. I just want plug and play. I have better things to do than try and install this rubbish over and over again. I fully agree with RandyG. DO NOT WASTE YOUR MONEY ON A RING PRODUCT.

1 Like

Well done. This solution worked first time for my ring pro. Nothing else would work but your suggested hard reset worked straight away. What a relief. Well done and thank you. None of this should be necessary but our ring experts should suggest this when good folks are struggling to set up.

1 Like

I did exactly as you stated and it worked! Saved me a phone call to Tech Support. Thank you!

1 Like

I bought this Ring doorbell on sale at Home Depot like 2 years or more, never used it until recently. Was sitting in my closet the whole time. I went to hook it up but first I replaced the transformer with the proper 16V one, it started to boot up, white ring going but the doorbell kept constantly going off and it never showed in my WiFi list either. Hours I spent tracking wiring, using my volt meter also. I am returning the transformer I bought and throwing this POS doorbell in the trash. Glad I got it almost half price, ■■■■■■ it is broken. Too many horrible stories with this garbage. I am getting a proper security system install and not wasting my time with this trash company.

I have just received and have been trying to setup Refurbished Ring Doorbell Pro which I got on Amazon Prime day.

I am also having the same issue with everyone here where Ring does not list in the wifi connections. When I tried with barcode it says cannot connect. It is really frustrating.

I tried resetting, rewiring, reseting the phone with no luck. This is obviuosly a defective product they sent me!

I asked amazon to replace it but now I have to wait 3 weeks for it to arrive as they are out of stock!

You should check your devices better before sending out to customers Ring!

Thanks SO much for tip. Worked like a charm for me!! Orange is my new favorite color!

1 Like

Everyone who’s having issues with the Ring coming up and not connecting… make sure you are pressing and holding the tiny little black button on the top right under the camera. The light should be circling white, not blue. I couldn’t get mine to connect from simply pressing the doorbell button in the center (light was circling blue) and not the tiny button under the camera. As soon as I figured that out, everything connected siimply! I hope this helps someone!

1 Like