No power to base unit

Hi. Just purchased and installed the Rinf alarm system. All going well then after a few hour me got a warning the base unit has no power .
I think the power transformer plug may not be working. I tried several different power sockets but no power appears to be going to the unit.
Any help appreciated , thanks

Hi @user35437. I appreciate you trying some troubleshooting steps to help resolve your concern! You can also try power cycling the Base Station, to do so, follow these steps:

  1. Unplug the Base Station.
  2. Open the battery compartment.
  3. Remove the battery from the Base Station.
  4. Leave everything out and unplugged for a full 30 seconds.
  5. Plug in the Base Station.
  6. Reinsert the battery.

If you have tried this step and are still having the same concern, give our support team a call at one of the numbers available here for further assistance. If you are outside of the US, please visit here to see how to contact support.

Thanks. Rang support and they issued a new base unit

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.