No notification via Alexa devices

Two calls to Ring CS with this same problem. They then referred me to Amazon Echo CS who suggested I call Ring back. Solved the problem per advice listed below…Shut off the Do Not Disturb function on Alexa Show. Thanks to commenter below for the advice.

1 Like

This is what fixed it for me, but it took me a while to figure out that the PRIMARY user’s email address must be the same as the Amazon email address; it will not work with a shared user account.

1 Like

This worked for me after been trying all other ways. Thanks!

1 Like

This worked for me. Thanks!

I tried all of the above with no luck, then I decided to disable the setting “Amazon Kids” on the Echo device and once I did that it worked!!! Now I can get the ring notifications on the Echo Show. I guess this is a bug on the app that should be fixed by the developers.

Mine worked until a few days ago and it just stopped announcing. I tried all things listed in this thread and it’s still not working. Any other ideas?

for me, that didn’t work