No Longer the Owner of the Device??

Noticed I haven’t been getting any notifications so I went to check my Ring App. First thing that was strange was that I had to log into my acct on my phone. Then once I got in it showed I had No Devices…whaaat? I tried to re-add my device and it then told me “This device is still registered to its owner.” Wth! I have to ask the owner to remove it from their account so I can add it?? Are Ring devices getting Hijacked?? So no device, no history, no location. Could someone have stolen my ring and now can see me come and go?? I’ve taken out the battery just in case. I still have original packaging and have only had one account. Please help.

Hey @Shaun_T. Our support team here can handle all device ownership escalations, so I recommend to reach out to them if you have not been able to find out where your device is located in the Ring app. You will need to make sure you logged into the proper email address and password combination to see the device. If you have indeed done this, ensure you do not have a duplicate location that it is on. Toggling between the locations can be found under the Main Menu > above Dashboard by clicking on the location you see there. Hope this helps and please reach out to our support team via chat or phone to get it sorted out further if you cannot!

Be sure that you are using the correct login. For some reason, it took a login with another of my email addresses. I am not sure how the incorrect email worked to log in but it did. Once I logged in with the correct email it once again showed all my devices.

1 Like

I own two doorbells, a chime and a chime extender.

I had to disconnect the devices due to Covid with everyone working/school from home due to bandwidth issues.

Its a month later, I log into my RING account, try to connect my devices and it says I’m not the owner, to contact the owner to get access.

However I AM THE OWNER - no one else.
I used the app on my cell phone, my login works, pass word works - I try to connect the device and can’t.

NOW I have Ring devices I can’t use - why would my ownership have expired or disconnected from all three devices and even scanning the device didn’t work to connect it to my login???