No live view

I can no longer see live view… it just reads “activating device” then it says to try and reconnect. I first noticed when I stopped getting motion alerts. The app says the device is fine… anybody else been in this boat?

1 Like

The same issue for me? I am trying to figure it out.

It just keeps spinning , grrrrr

same here. i can access the camera if there is an alert like motion or doorbell ring, but cant access live view. always say reconnect.

I got the same issue. Its not my internet speed or battery. All my devices show as healthy. Ring pls help here.

Hi neighbors! Video connection concerns are often related to wifi, mobile device, or Ring app communication variables. The best first thing to check is your wifi signal strength, or RSSI, which can be found in the Device Health section of your Ring app. Check out our Community post about RSSI for tips on optimizing this signal strength.

Removing and reinstalling the Ring app is a quick way to ensure it is up to date and optimally integrated with your mobile device. On your mobile device, try testing video on wifi only, and then on data only, to see if either connection is more efficient. Please also ensure bluetooth and VPN is disabled to ensure all processing and connections are dedicated to your mobile device and the Ring app. I hope this helps! :slight_smile:

My live view stopped working right during the banging and bright flashes of the close fireworks. The camera view shows up the event but says the camera is offline. I tried logging the camera back on several times and got it to log back into the router, but still no luck on the live view. I reloaded the Ring app and it looked like it worked for a short while, but live view stopped and camera shows as off line again. When I did get live view to connect, all I got was a black screen. My smart phone and my computer show the same results. I see that many people have reported the same problem. I have tried a couple of things with the router but no luck with that. Anyone out there been able to figure this problem out yet?

Usually when you can not connect to Live View it is attributed to a connection issue. Are you running off cell data or wifi when trying to connect to Live View? Also, have you tried downloading the Rapid Ring App to see if that makes a difference? Let me know!