No live view and stuck on activating device

Update on my previous post. I’m regularly having this problem, and the only thing that reliably works for me is this:

  1. Close the ring app completely. On iOS I load up all my apps and forcefully close it.
  2. Open the ring app and go to the settings for your camera/doorbell. Do NOT go to live view before doing this!
  3. Go to Device Settings -> Video Settings
  4. Turn off Live View
  5. Wait 5 seconds
  6. Turn on Live View
  7. Exit the app like in step (1). Make sure you forcefully close the app completely
  8. Open the ring app and go to live view. For what it’s worth, on this last step I wait a good couple of seconds after opening the app until I click on the camera/doorbell, then another second before I click on Live View.

There’s clearly a problem happening somewhere between the app and the device or cloud server. Ring should be prioritising looking at this, there is definitely an issue.

Hi, neighbors! We recently updated our Status.Ring.com page in regards to a live view concern we found. If you visit the status page, or viewed the Community announcement, you will see this live view concern has since been resolved. Your live view should operate as intended. If it does not, please try removing and reinstalling the Ring app on your mobile device.

Video connection concerns are often related to wifi, mobile device, or Ring app communication variables. The best first thing to check is your wifi signal strength, or RSSI, which can be found in the Device Health section of your Ring app. Check out our Community post about RSSI for tips on optimizing this signal strength.

On your mobile device, try testing video on wifi only, and then on data only, to see if either connection is more efficient. Please also ensure bluetooth and VPN is disabled. I hope this helps! :slight_smile:

I’m having the same issue with my stick up cam. The ring doorbell works fine but stickup cam started getting stuck on activating device and no live view. I uninstalled it and now I’m unable to add the device back. I get to the connecting to the internet and it fails saying theres an issue with my internet. However the device worked fine for months and the doorbell is still working fine. Ring sent me a replacement stickup cam after hours on the phone. New cam went through setup fine, connected and then the ring cam performed an update and now it won’t connect. Same issue as the first one… I’m using an Apple Airport and there’s been no changes to my network. I now have a device and subscription that I cannot use.

Well I have a iPhone 7
When I use my wifi from home I can watch live view on my floodlight cam
When I’m at work and use my data of my phone I can’t connect to live view
Just keeps spinning around and around
Now this problem has only just happened in the last week
I have done all the updates on everything
Deleted apps and installed
I’m at the point where I’m about to rip it of the wall and return it and find something else

1 Like

Same issues here…

Same problem… I installed Ring on a sunday night, subscribe to de anual plan, and already on monday morning it missed some events. On tuesday at 9:30 was the last time it recorded anything. Now, I’m not able even to check live view. Not showing any connectio problems, signal is very good, its litterally on the side of the router. waste of money

still does not work, where is the answer

this is the solution? I have done all of these things and still not able to go live. If i turn off live view in settings and force close the app and wait a few seconds then open and turn live view on and then force the app close and wait a few seconds again. I then have to go out to make the settings stick (most redundant feature ever). Then I can get it to work…one time and then it does same thing. Strangely my trial period ended and I will not be subscribing with these issues. I have until end of January to return it. Looks like i’ll be doing that over the weekend. Let me have the option to save the clips to my phone or computer without a subscription.

1 Like

Our house is having this exact issue with our Ring Pro as well. I’ve done many router and gateway reboots and it’s not an internet speed issue as we have over 200Mbs down and up. It was working fine until about a month ago when it stopped responding or responding very infrequently to both my wife and my phones.

This really feels like some kind of update busted it or maybe it came along with the new iOS?

Ring peephole cam has had this issue since the infamous Ring outage in November. Battery re-seating, network reboots, and factory reset has not resolved this issue. I’m guessing it’s a software bug, and Ring has had a couple weeks to fix this vital, mainline feature. What’s going on with the dev team? This should be the main priority right now, and should’ve been fixed within a day after the outage happened. If my device has been seemingly bricked, then reach out to your customers about it. Don’t make me sit another 30 minutes on the phone to be told to reboot the camera…

My live view is stuck more often than not (about 80% of the time). I’m using an Eero Pro mesh router 5ghz, so my network strength is not the issue. I’ve only had this product (doorbell) about two months, and I’m very disappointed with this service. It worked better the first month with the free trial subscription to record the videos on their server, but if you don’t opt-in for continuing the subscription, it seems the usefulness and quality of experience with live-view drops significantly. The motion sensor seems to work fine, and I get a notification, but can’t open the camera or microphone in time to greet anyone. I bought this to view and answer the door remotely from my office. I don’t care about saving recordings. If I can’t have real-time live view, then neither the people at my door nor me can interact with each other. Again, I’m so disappointed. If it’s their extortionate practice to get you to sign up for an ongoing subscription just to make this work, I’m going to look for another option.

A friend just gave me a Ring Floodlight Cam because he just switched to another brand. I was elated so I went out and purchased a Stick Up Cam and a Spotlight Cam to accompany the platform. Now I’m starting to understand why he switched. I’ve been a Network Administrator by trade since “97” and know what I’m doing when it comes to networking. I also have GIG internet to my house and an extremely powerful router and wifi extenders throughout the home and have no latency issues on any of my devices throughout. My finding so far is that the live view problem with this app isn’t network related. The app is extremely inconsistent in activating any of the cameras no matter what the signal strength to the camera looks like. To compound this I’ve had to set the cameras within 2 feet of the router or extenders to get anywhere near an RSSI of 20 to 30. On last test with the Stick Up Cam I received an RSSI of 22 which is well within Ring’s acceptable range and gets the Ring “Clean Bill of Health” report in the app. Still no change. Live view sits and spins with “Activating Device”. I try to reinitiate but the success rate is highly inconsistent. It may take 3 to 5 attempts before it finally avtivates. This isn’t acceptable performance for a product of this price. I have some blink cameras on a much slower wifi network at my Mother in Law’s house and have never even seen issues of this scale. Already requested my return label. SMH…Come on Ring…

Same here. I have no issues with my wifi or home router and we have many devices connected to it but these dam ring doorbells only connect to live view about 50% of the time, and it’s sooo frustrating. I have great RSSI signal too and I sit there and stare at that stupid “Activating Device” screen all the time. Class action lawsuit sounds great to me. If I (or ring) can’t get this issue fixed then I’m replacing them with something better.

This worked!

1 Like

I tried deleting the app and downloading it again. No luck.

It is NOT a wifi issue.

We are at our wits end. What is the point if I cannot see Live View? Ring needs to fix this ASAP.

I have a Ring Doorbell Elite. No “Live” issues EVER (not that I would expect with POE). I have 2 Ring Stickup Battery Cams. No “Live” issues EVER. I’ve had the Ring Doorbell 3 for a couple months now with consistant “live” view timing out until the devise it reset…again and again. While it seems to record all motion, upon opening the APP it’s always stuck on a couple of days ago, while my other devises ALWAYS show seconds ago…AKA “live”. NEVER and issue with the other products that are even further away from WiFi. Ring products should just…WORK. Don’t get me wrong, I’m a fan of the whole “Ring concept”…but this product, ain’t right. Please address this SOON!

I couldn’t establish connectivity to any of my Ring products when I was away from home.

I resolved this issue by disconnecting and eliminating my Amazon Echo from the configuration.

Everything works perfectly now and can see Live feeds for all my Ring products through cell service when away from home.

I couldn’t establish connectivity to any of my Ring products when I was away from home.

I resolved this issue by disconnecting and eliminating my Amazon Echo from the configuration (unplug it so it’s powered off).

Everything works perfectly now and can see Live feeds for all my Ring products through cell service when away from home.

Was it just showing in your echo feed for thirty seconds then buffering and stopping? If so is this how you fixed the problem?

For me, just pulling the battery out of Ring Doorbell 3 Plus for a hard reset initiated a software update. After which it was able to connect to ring.com and live view (after not doing it for almost 3 weeks).