No connection, battery not charging

I bought a ring stick up camera for outside last August. A few days ago it started saying it wasn’t connected to the internet and had no signal. It was charged (68%) and my internet was working ok. I completed the trouble shooting process but it still wouldn’t connect. I pressed the orange button to reboot but no blue lights flashed. I reset my internet and that made no difference. When I plugged the battery in to charge no orange light came on only a green one. The battery is not fully charged though as it hasn’t been charged for a month. I tried different a different plug/cable and the same thing happened. I deactivated the camera to try and re add it to see if that worked but it didn’t. Surely the camera shouldn’t stop working after just over a year? My ring doorbell one is working fine still so I know it’s not an issue with the internet here. Has anyone any advice please? Thanks

Hi @GillyP. A green LED on the battery indicates that it is fully charged, so that shouldn’t be the issue. Put the fully charged battery into the Stick Up Cam, then hold down the setup button for at least 20 seconds. After the reset is done, try to set the Camera back up in the Ring app using the steps under Set Up a Device. If the Camera isn’t responsive to these troubleshooting steps, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.