New wifi ~ ring doorbell will not connect and I have tried every instruction

New wifi - no big deal, all my other 20 devices connected very easily. Tried with my RING doorbell and I get sent into the loop of never hooking up. I went through all the instructions and did all the ideas and nothing. The internet router is close so that’s not an issue. ANY ideas??

1 Like

Same with mine! I ended up deleting all of the devices out of my list, now it’s trying to connect to itself…? Makes no sense. The Ring tech-support sucks!

Hi there, neighbors! Being close to the router is a great start, as is making sure the battery is charged fully. If possible, try performing this setup process using another mobile device entirely. Please also ensure there is not a VPN enabled.

The next best step, if setup has not completed still, is to perform a reset. Holding the setup button on your Video Doorbell for 20 seconds will reset it. Once this step is completed, try setting up or reconnecting your Ring device in the Ring app.

If this concern persists despite trying all of the above, our support team will be able to provide more advanced solutions. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

I know this is an old forum but wanted to leave a suggestion for you or anyone else who couldn’t figure it out, since I’ve done this about 900x this past month for newly purchased devices. For most users, accessing the Admin website for your modem is how you’ll do this. If your cable/internet provider allows you to access all of your backend modem settings from an app (lucky you), you’ll just use the app.

  1. Anyway, you’ll need to separate your WiFi bands from a combined 2.4/5 ghz to separate. Leave your 2.4 ghz the same name/password as it was originally (Example: While the bands were combined, your username was ‘Person123’ and your PW was ‘Person123’). Once you’ve separated the bands, rename ONLY the 5 ghz and change the password to something easy to remember, like wifi12345 or something (this is temporary).

  2. Go into your app/admin tools. (Example: Spectrums admin tool URL—without spaces—is 192. 168. 0. 1; Xfinity—without spaces—is 10. 0. 0. 1)

  3. Navigate to the section of your app/admin tool where you can allow filtered MAC addresses onto the router. There should be a way to “allow all” or “allow” (the wording can vary depending on your modem/provider). For good measure, you can manually add the device (if you know the device MAC address). The name of your device is normally the MAC address, as well. Save your settings.

  4. Return to the device you want to connect to WiFi and go through the steps to connect. Your device should now be able to connect.

  5. If connected successfully, go back to your app/admin tool MAC address filtering page and make sure that your Ring device is still under the “allowed” section (if you selected the “allow all” setting on this page in step 3). If successfully added under the allowed devices, switch your settings to only “Allow”. If you select “Deny All” or “Deny”, it could remove the MAC addresses but is unlikely. look up the specifics from your provider/modem for more detail, as it can vary.

  6. Switch your WiFi bands back to combined. All of your old devices, and new, should automatically reconnect and stay connected (that’s why it’s important to retain the name/password on your 2.4 ghz band :blush:). Just be sure the Username/Password is the same as the 2.4 ghz band/original WiFi name. Or you can leave them separate—it’s up to you!

**If opening up MAC address filtering doesn’t connect the device, you can try adding the device in your app/admin tool with a “Reserved IP” before going to step 3. Also, setting up a DMZ for your device can also work, but I’ve found it hardly ever does. Lastly, you can try doing all 3 of these things (MAC filtering, DMZ & Reserved IP) to force devices to connect to WiFi. Splitting the bands and opening MAC address filtering is the only thing that’s ever worked for me.

Good luck!

3 Likes

Hey @AJ43576492. Thank you for this very detailed solution!

1 Like

AJ, thanks for the detailed instructions. This is the closest I’ve gotten to getting this unit functioning. Going to try again with fingers crossed!!
Thanks!!

1 Like