New video doorbell not working

I was bought a video doorbell 2nd generation for Christmas yesterday. I have tried to set it up and all the settings in the app says it is set up and working but it doesn’t ring when the bell is pressed and it doesn’t send any notifications. The live video doesn’t work either. The only thing i haven’t done is actually fix it the wall as I wanted to test it first. I have put the back on and put the screws in as though it is up though. I’ve deleted the app and reinstalled, I’ve reset and set up the bell twice but nothing makes a difference.

Sounds like you might have a network/firewall problem.

It’s saying my WiFi connection is good when I go on the device status bit. What do I need to do to get round the network/firewall problem? I’ve tried doing it through alexa too as that can’t connect to the video either.
Thanks

You are in the US ? You have a major ISP ? What is the model of your modem/router ?

Do you know how to access the configuration page for your router’s settings ?

I am in the UK, I can access the routers settings. My router just says plusnet on it as that is my ISP.

Go to your router’s settings and disable the firewall - just to test if that is the issue. You can enable it afterward.

Disabled all firewalls and still nothing is working.

Ok - does your router’s config page show something like ‘connected devices’ ? you should see your android device amongst others. Do you see your ring device listed ?

It isn’t on the connected devices list but it is listed somewhere else on a port forwarding list. (was just flicking through options and noticed it)

Well if it were me - I would record the current settings and then - remove any sort of ‘port forwarding list’ entries. (associated with the ring device)

The port forwarding thing is only an option to choose the doorbell, there aren’t any port forwarding things set. (no idea what it is to be honest)

Well let’s see…

  • The router does not see your ring device - right ? (It is not showing up as a connected device)
  • If there is not that connectivity then nothing will ever work.

Next - if it were me - I would try connecting via my cell phone. Can you set you cell phone up as a wifi hotspot ? (on thin ice here).

Edit : which version of the ring device do you have ? which band (2.4/5.0) are you trying ? Make sure you try 2.4 for starters.

I’ve just tried reconnecting it to the router and it gave me a different option and the bell worked once but still didn’t show me video. It then said its updating but has been doing it a while. Its flashing 15 times, once per second then off for 5 seconds then starts flashing again.
I can’t figure how to get my phone as a hotspot. I’ve got the ring video dio 2nd generation.
My network is showing as 2.4ghz and 5ghz. It doesn’t give me the option to choose which it goes onto but my phone runs on 2.4 and everything else is on 5.

So I assume your device is in the process of updating the firmware. That should not take more than 15 minutes (and you could have ‘skipped’ the update).

So when that update is done - does your router’s config page show your doorbell ?

I’m just about ready to sign off for today. Bottom line - the router has to see the doorbell…

it must have been flashing for over 20 minutes. it still doesn’t show on my router page. thank you for all your help, i’m giving up for tonight as its nearly bedtime.

i’ve just reset it and started again. it did show up on my router page, i skipped the update but then its started flashing again and disappeared from my router list. i’m going to leave it flashing overnight and see what tomorrow brings.

Mine is doing exactly the same. I’m in the UK as well. Blue flashing light 15 times then repeats. It’s been “updating” for 4 hours now. Very frustrating!! It’s not my internet that’s the issue as it all says everything is okay and firewalls are off. Did you have any luck with leaving it overnight?

In all honesty - I think you both may be subject to the holiday ‘crunch’.
My Ring doorbell has been performing - no worse - than it was say a month ago.

From my experience - you can skip the firmware upgrade and tackle that later.

(What ever happened to Ralph Nader ?)

It was still flashing 12 hours later. I phoned customer service and they went through everything and are sending me a new one out.
Charlies, thank you for all your help. I could say to customer services that I had tried most things and it didn’t make a difference.

1 Like

Terrible customer service - best of luck… I have been waiting for parts for two months… worst purchase decision ever.