New RingPro doorbell lost power but is hard wired

I just moved into a new house, and the ring pro doorbell was installed and spinning white when I moved in. I managed to set it up to my account and connect to wifi but it then needed to update. Once it updated it lost connection so I went to reconnect. I couldn’t get it to enter set up mode pushing the orange button on the side and suddenly it turned off completely.

I can’t get it to turn back on, nothing on it works, and it seems to have completely lost power even though I didn’t mess with any wiring. It almost seems that by pressing the orange button in what ever combination I did bricked the device :man_shrugging:.

Can anyone help me to get it turned back on? (The light is off completely, I tried holding the orange button for 15 and 30 seconds and nothing happens, and pressing the door bell button gets no response)

Hi @TheGovNa. I would suggest power cycling the device by removing power going to the device for 10 minutes, then reconnecting power. If you still do not see any lights coming from the device, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Ya that didnt work to disconnect it. Also had an electrician over and he said transformer and power were good.

How could i have bricked it pushing the orange button. Is there like a reset i can hit with a paperclip or some button combo to turn it back on?

Hi @TheGovNa. There’s no way for me to be able to tell what may have happened. Your best bet is to contact our support team so they can run some diagnostic tests.