New Ring Pro will not enter setup mode.

I’ve just moved into a new build home and the entire neighborhood comes with a new ring pro. Mine will not enter setup mode. Just stays flashing white ring. I’ve tried the factory reset numerous times no luck. I don’t think it’s the power issue because the house is a new build. Please help!

Hi @TStarr2. I would try to disconnect the Ring Pro from power for 3 minutes, then reconnect it to power. Allow the doorbell 1 minute to reboot and you should be able to enter setup mode. Let me know if this works!

Hi Tom,

Sorry for the delay. No shutting off the power and turning it back on did not fix it. It just stays on the flashing white ring and will not connect to the “ring” network.

@TStarr2 Thanks for letting us know how that worked for you. Since you’ve also tried to reset the Doorbell by holding down the setup button for at least 20 seconds to no avail, it may be best to follow up with our support team on this matter. They’ll be able to pull up your account and device and provide more advanced troubleshooting steps in order to get to the bottom of this. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support. :slight_smile: