New ring pro 2 doorbell recordings skip/jump/glitch after 5 seconds then continues after 3 seconds of footage is missed

I have a ring pro 2 doorbell. I noticed my recordings skip/jump/glitch after 5 seconds. It pauses for 3 seconds then continues, but then I’ve missed those 3 seconds of footage. Does anyone know why it’s doing this? I’ve done majority of the trouble shooting recommendations - the ring app is up to date. My phone is up to date. I tried force stopping the app. My router is nearby. My transformer voltage in device health shows “good.” RSSI is -51, etc. I’ve searched this whole thread and nothing has helped. Can anyone please help?

Hi @user73737. This sounds like your doorbell is suffering from packet loss. There are a few things you can try to improve this. First, ensure that you are using the proper ports and protocols for Ring. Next, adjust your WiFi channels. If you are still having this concern, reboot your internet router and try connecting to your 2.4 GHz network. As a test, connect your doorbell to a WiFi hotspot to see if you still have this issue. Let em know how this goes.

Hello and thank you for your response. I did both of those things you recommended and had no progress. I switched to channel 11. I called Spectrum. Spectrum said my ports were not blocked. I got a new router (tp link) and I’m still having the same issues where the recordings are glitching. I want to mention that my installer did not add the power kit to my indoor chime. The installer said the doorbell power is strong and ringing fine without the power kit. Would the lack of a power kit cause this issue? Please help.

Hi @user73737. Thank you for attempting those troubleshooting steps. If you’ve tried connecting your device to a WiFi hotspot and you’re still getting poor video quality, you’ll need to reach out our support team to look into this further. You can send us a message on Facebook or give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

I have this exact same issue with the same doorbell. I’ve had this doorbell for a year and it only started recently so it’s most likely a software issue that Ring messed up. At the same time, the Ring app setting for disabling in-home chime stopped working as well so they definitely messed something up huge

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.