New replacement doorbell Pro burning out multiple transformers

Hi All,

Weird issue I’m having. I recently got a warranty replacement for my 3 year old Doorbell Pro due to the front glass cracking all over.

My original set up was this:

16v 30va Transformer > directly connected to Doorbell Pro (No powerkit inline)

This set up never had an issue up until the new replacement came. I shut off the breaker, plugged in the new doorbell, turned breaker back on. The new doorbell needed to be internally charged before powering on so I let it do it’s thing for a couple hours. Once booted, I set it up and everything is fine. The next day, the doorbell is offline. Turns out, the transformer was no longer outputting power. Doing a search online and asking someone who has the doorbell, they informed me their 1 year old doorbell pro required a powerkit. I saw this Power Kit v2 box in the box and thought… Why would I need this if my old doorbell worked all these years without one??? So I figured they must’ve changed how these things were built some how.

I put in the power kit v2 inline as the following setup, I do not have an mechanical chime:

Transformer Wire1> Power Kit v2 via Bypass ports > Doorbell

Transformer Wire2> Doorbell

Did the whole set up and everything worked fine. The next day or two, I again find the doorbell offline. At this point I blamed it on maybe the brand of transformer just sucked or a defective product. I went to Home Depot and returned the transformer and got a replacement one of the same brand. Same thing happens! So I went on Amazon and bought the NuTone C907 16v 30va transformer like my original one. AGAIN! The same thing happened. Dumbfounded, I tested the wires for Continuity with my multimeter to see if theres a short somewhere… NADA. So I contacted Ring and figured the replacement Doorbell Pro was faulty. They sent me a 2nd replacement Doorbell Pro.

I went and bought my 3rd replacement transformer and plugged in my ORIGINAL doorbell pro and it stayed on for a week. At this point I was so sure that the 2nd replacement Doorbell Pro would work now. So I went ahead and plugged in the new replacement doorbell into the new setup with the power kit v2 in line, and the next day, BAM! The 2nd replacement Doorbell Pro killed my transformer. So now I’m lost and waiting for my 4th transformer to come (that’s ~$80 down the drain already!). Before I do anything else, I was hoping someone could give me some insight as to what in the world could be wrong. I feel like the wiring is very straight forward when connecting directly to transformer so what could possibly be wrong???

List of some background info:

Every test, the wires behind the doorbell read 16-17v

Every test, in the app the power showed 4.0? and showed good power

Signal on wifi isnt an issue

Power source is grounded

Lights that are connected to the same junction box has no issues

3 year old Doorbell Pro does not burn out transformer, only the new replacement units

Thank you for your time.


I got the same problem. I burnt two transformers. I called Ring for support and I did not get any help. I am going to return my video doorbell pro which is useless. JFM

1 Like

Hi neighbors! Is there anything showing that the transformer itself is no longer powering, or is it the Video Doorbell Pro that is just showing offline? The Transformer should still be outputting voltage, and the Doorbell Pro will only draw power at a rate that should not exceed a new transformer.

As you mentioned having a multimeter, a great step will be to check the transformer after the Pro goes offline to decipher whether the transformer stopped powering, or if the Pro stopped receiving power. When wiring directly to a transformer, using the Pro Power Kit in bypass mode is the best step. As I see you’ve covered this step, the Doorbell Pro should be working as intended.

Please ensure there is not any resistance in power, which can be caused by thin wiring, old wiring, a very long wire run, or a short in exposed wiring. Once your Ring Pro is setup in the Ring app, it is important to also select No Chime from the Doorbell Pro’s settings in the Ring app. If this does not resolve your concern, feel free to include pictures of wiring at the transformer and behind the Pro, for a closer look.

Same problem here. Transformer eventually burns out because at some point the ring doorbell fails and shorts the circuit closed. The doorbell does half a ring, hums, then burns out. I ordered a new transformer and it did it again. Ordered another transformer and returned the doorbell for a new one. Problem is not happening anymore.

Another victim here. Same problem. Ring pro burned out my first Ring transformer after working well for about 13 months. Ordered a new Ring transformer, same model as before. One ring burned out the second transformer. There is obviously a short on Ring doorbell pro somewhere. None of my wires have been touched or changed, no way they’re shorting. Since the camera worked for a few minutes, it confirms that my wires are fine. Only when I pressed the button, the transformer popped.

1 Like

Same issue here - I have had 2 ring pro doorbells & used the Ring transformer - installed by an electrician. They both worked fine for around 4 months before the transformer died. Looking to get a replacement to try one final time.

Hi neighbors! If none of the solutions offered in this thread previously are helpful in resolving your concern, I would recommend touching base with our support team to follow up on this. They’ll be able to take a closer look at your account and device and offer more advanced troubleshooting in order to find a solution. You can give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

What was the resolution?

And the problem continues. I have the Doorbell wired and it burned through two transformers. Original and a new one. Called support and they suggested I use the 2nd generation power adapter (which plugs into a wall outlet) to resolve it. Are you kidding me? Worthless product.

Same here
2 week old Ring 3 (non pro)
Hooked up battery powered, finally had time to go wire in the doorbell transformer , worked a few days then all of a sudden low battery , check transformer and dead
Replaced it, started smoking within 3 min
Replaced again w/in-line fuse , blew fuse.
Transformer putting out proper 24v AC
(HVAC Tech for 20 years I know how to wire a transformer)
Tech support seems useless so far.

1 Like

Hi there, neighbors! Your safety is definitely a top priority here. If this is happening multiple times, it’s best to check any wiring variables such as wiring gauge, transformer type, and more. For those with a Doorbell Pro, this Hardwiring Checklist is a great resource for optimizing power.

@Mgoerke, as you mentioned having a Video Doorbell 3, check out this Hardwiring Checklist for battery-powered Doorbells. As you mentioned checking most wiring variables, please also ensure the proper chime type is selected in the Ring app. To change your chime type, follow these steps:

  1. While signed in on the Ring app, visit the Menu.
  2. From the Menu, select Devices.
  3. Choose your Video Doorbell.
  4. Select the Device Settings tile.
  5. Choose In-home Chime Settings (For Video Doorbell Pro, select general settings)
  6. After selecting the appropriate option for you Doorbell model, in step 5, please check these chime type settings to ensure the proper type is selected (mechanical/ digital). If there is not a chime kit in use, please select none.

If this concern persists despite following the above recommendations, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. Any advanced wiring concerns or questions should be fielded to a qualified electrician.

1 Like

Have had the same issue. Doorbell worked a year plus than failed. Metered the transformer and it was shorted. Replaced the transformer with a recommended transformer and it lasted 5 days. tried two other transformer and both shorted. Replace the Doorbell with a competitors and it works fine, other than the performance is lacking with the replacement. Ring needs to acknowledge there is a design or engineering issue and warranty this problem. I’m out $60.00 on transformers and $170.00 for the replacement device.

Hi @mkjr. Thanks for sharing your experience here on the Community. When it comes to a device not working or this instance of transformers or even the Ring Doorbell being damaged, I strongly urge you to contact our support team for further assistance. They can pull up your account and properly log this concern and advise on what troubleshooting options are available. You can give our support team a call at one of the numbers available here.

I’m having the same problem. Unfortunately, contacting customer service is not really possible as the hold times are like hours long, and as I learned after an hour hold today not a lot of help was offered.

It does sound like, in reading all this over, it’s very possible the Ring Pro doorbells are failing, developing shorts, leading to all these transformers failing.

In my set up, I’ve only got inbound 120 VAC power, Ring-branded transformer, and Ring Pro unit, ie no separate wired chime. In subsequent research I can see that earlier generation bells required a resistor in this setup, but that it’s not considered required with the Pro unit. Is it possible the Ring pro actually does need the current knocked down when there’s no wired chime connected?

Curious if others experiencing repeat transformer failures are also set up this way, with only a wifi ring chime?

It’s sounds like you solved for a lot of variables. The last thing is to be sure that there are no pumps or garage door openers on the circuit. This could be causing an inrush spike and shorting the internals of the transformer.

1 Like

Great callout @Engineeringkarate. It is a great idea to ensure that the Doorbell circuit is isolated and does not have other circuits tied in to the transformer.

1 Like

I have burned out 8 new transformers (Hampton Bay from Home Depot 16V 30VA). I have the power kit in bypass mode. Setup is transformer to bypass mode power kit to RING. (original doorbell chime excluded) At first thought my line bad so I spent a week running new 18/2 wire to front door (less than 50 ft). Nothing matters. Initially burned out in a week, but now transformers burn out in a few hours. This is NOT power surges, NOT a faulty wire (this is new wire), NOT a transformer issue (after 8??). I have a degree in engineering. This is a poor product design. Now over $400 into it, I need to throw the whole thing into trash and reconnect original doorbell. As I read on internet, this is a not uncommon problem.

Anyone have a solution to this? We have a Doorbell Pro that has burnt up two Ring Transformers. Nothing else on the circuit, wired directly.

Same issue. New Doorbell. Ordered the ring transformer. Blew that transformer. Bought a transformer with the same specs from home depot, added in the ring power pro via the bypass, also switched the wires to 18 gauge solid doorbell type wire just in case and blew the 2nd. Read about setting the in home chime to none since I am using Echo devices as my chimes. So I wired transformer #3 from home depot. This time it worked longer, but a few hours later it blew while showing motion at the front door.

Just checked the terminals on the back of the doorbell for continuity with the wires still attached. No continuity, .476 ohms resistance.

Any solution here? I’ve burned through 3 transformers (2 Ring, 1 Broan-NuTone…all 30VA rated) with 2 different Video Doorbell Pro 2s. I’ve changed my wiring (upgrading from 22 gauge to 18 gauge)…but same problem. Ring works for 2 days or so and then stops…voltmeter on Transformer shows it outputting 0 volts so I assume it is fried. Interestingly, the only transformer that did not burn out was the first one I was using, a generic 20VA doorbell transformer…but it ran very hot and buzzed terribly, which is why I upgraded it to a 30VA transformer from Ring. That’s when my problems started. Electrician confirmed no obvious short on my line.

FYI…my Ring Video doorbell is direct hardwired to the transformer (max 12 foot run)…I didn’t have an existing doorbell chime (mechanical or digital)

Ring Tech support keeps sending me replacement Video Doorbell Pro 2s…after 60 - 90 minutes on the phone dealing with some poor tech support jockey reading from a script…but given that this has happened with 2 different devices, I am reluctant to install a 3rd.