New refurb Ring Video Doorbell does not complete setup

Have a “new” refurb Video Doorbell and it doesn’t complete setup. Gets to “firmware update”, flashes white ring (several minutes), goes to flashing blue ring (one or two minutes - reboot?) and then back to flashing white ring then blue ring, etc. Never completes, never able to get to live view.

Hey @Jmtok. Could you try resetting the device by pressing and holding the setup button for 30 seconds, and then trying to trigger a Live View? If the Live View still doesn’t work, please remove the Doorbell from your app, reset it again, and then set-up the device again. This will help the firmware update again, which should go through. In the event this may still not work, please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19. This has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Yep, thanks, called support and they confirmed the unit is defective. Shipping a replacement, which is awesome!

2 Likes