New install, keypad wont connect.

I’ve tried doing a factory reset on everything, still can’t get it to connect. I’ve had no problem connecting the range extender and the motion detector. What do I need to do to get the keypad to connect?

3 Likes

Great job getting those other Alarm components setup! The Keypad must be plugged in order for it to complete the initial pairing. If it is still not communicating with your Base Station, or adding in the App, try holding the “1” on the Keypad to perform a soft reset.

Unplugging and plugging back in might help as well. Although you’ve already performed a reset, if multiple Alarm devices attempted to pair at once, the Base Station will accept one and put a “hold” on the others until it is ready. Are there any LED indicators on the Keypad that stand out to you, or are you receiving any errors while trying to add?

I’m having the same problem. Everything but the keypad connects no problem. I’ve done soft resets and factory resets multiple times and no luck. Upon plugging in the keypad I see a red network icon, a green battery icon and a spining blue indicator. After about a minute the blue indicator stops and the ring blinks blue three times. Then nothing. The ring app says “waiting to connect to a network”.

1 Like

I had a similar problem, in the app when before you select Keypad on new device there is a “manual entry” mode at the bottom of the page. Select that and then plug in the keypad. It binds the device in reverse.

3 Likes

Sorry to hear you are experiencing something similar, @kregli . To confirm, you have tried unplugging and plugging the keypad back in? If so, and you have tried a factory reset then I recommend contacting our support team to assist with the next steps for a proper resolution. You can contact them at 800-656-1918. Feel free to let us know how it goes, and what solution you found.

I am having exact same problem as described here, and have performed all rudimentary troubleshooting steps. Is there a known quick fix at this point that will save me a support phone call? Please don’t tell me to reboot /unplug or press the “1” button!? I have also tried manually adding the keypad in thr Ring App. This is extremely frustrating and adding hours/days to what is supposed to be a very simple setup process…

There is a very small reset button on the unit. I think it was on the back. One of those insert pin types. I’ll double-check where as soon as I get home and try to post a picture.

Thanks - but I already tried the reset process, to no avail. However, did it work for you?

Yes. This the little pin hole on the back. It did a factory reset of the unit. I pushed it in for a few seconds. I also removed it from the devices in the app first.

Yeah thanks, I tried that also, pressing the “5” key whilst doing so as per Ring instructions… didn’t fix anything. All my other devices are connecting just fine so I think the keypad has some terminal Z-Wave problem I need to talk to Ring about directly. Thanks again.

1 Like

Here is the key:

  1. go to main ring app thru your phone

  2. select devices

  3. select base station

  4. hit the “settings” gear icon in the upper right hand corner

  5. section advanced options

  6. select Z-Wave

  7. Select remove Z-wave device, then push #1 on the keypad

It should indicate device succesfully was removed, then in 20 seconds keypad should add into system

19 Likes

Perfect! This actually works, and validates the Z-Wave hunch I had earlier. Thanks again for figuring this out, and saving me hours on hold w tech support.

2 Likes

This needs to be added to the top of ring troubleshooting pages. My keypad randomly stoped working even though its running on its internal battery. I then spent hours trying to reset it and get it to pair with the base station.The process you have suggested worked perfectly thank you for sharing.

Great tip tried everything else then saw your post and it had my keypad up and running again thanks so much.

thank you so much: this worked! i have a motion and a door sensor and they are also not connecting. do you have any idea how i can fix that?

Hi the only issue I know regarding sensors not connecting is where the tab has been pulled too early I did this myself. The fix is to on each sensor remove and reinsert the battery this will then allow them to reset and be discovered as if you have just pulled the tab. Hope this helps.

ring does not work, Why ?

ring does not work, Why ? Because it doesn’t work…
Can you please at least tell us your problem in detail?
Tell us what you tried to fix it?

Or you could just call customer support

I just renewed my protect plan, how lown does it take to turn on ?

Hey @klowry923! If you’ve recently renewed your Protect Plan for Professional Monitoring purposes, please ensure your account is registered for this monitoring through the Ring app. If so, the plan should be active soon after renewing, or by this time. If it is not, feel free to reach out to our support team, at 800-656-1918, for further assistance. :slight_smile: