New Homeowner - Connected to base station but rest wont work

Worked fine at first. Contacts would beep when entering the home, etc.

Tried to make a ring account. Connected my base station to my internet. Now everything else says Waiting to Connect to a Network.

I have unplugged the keypad. I have held “1”. I have reset the base station. I have switched from wifi to ethernet. Nothing seems to get everything connected.

Hey @Cgh129. Could you try removing all of the devices (the keypad, extender, sensors, etc), and then re-setting them up? If you have them installed already in the location they need to be in, this may be why. When setting up the Ring Alarm devices, it’s recommended to go one device at a time, setting them up and added them into the system one by one by scanning in the code, pulling the tab, and so on. If you installed the devices in the location they need to be, they can have issues connecting to the Base Station for the first initial setup since the Base Station is however far it is from the devices, which normally need to be right next to the Base for the initial installation (this is during a time that the devices need to install the latest firmware, and need a fast/stable connection to the Base unit through Z-Wave (not wifi related)).

If this task seems too daunting, or you would like someone to take a deeper look into your account to see why the devices cannot connect still, especially if you have no luck after removing the devices and re-adding them, please reach out to our support team here.

Just tried adding a few things. Reset the keypad on the back, scanned the code, plugged it in. Still nothing

I see 2 devices trying to connect at the same time. This won’t work. You need to do one at a time. They need to be near the base unit when you connect them too.

This might help.

facing the same issue. only able to setup base station and keypad.

contact sensors and range extender won’t connect.

made sure that other devices have batteries removed while attempting to connect one.