New firmware rolling out that breaks ethernet connectivity?

Anyone with Stick Up Cam Elites on Ethernet noticing their devices go offline?

I have a half-dozen Stick Up Cam Wired (2nd gen), all powered over ethernet, and over the last couple days have seen 1-2 go offline each day. Pressing the setup button and connecting to Wi-Fi seems to work, but haven’t gotten them to reconnect to Ethernet yet.

Preliminary skim of switch port logs show the Ring camera changed its wired MAC address from the expected address (printed on the device; registered to one of Ring’s suppliers) to an unregistered MAC address. Wireless MAC address remains the one printed on the device.

If it was just one device, I could be convinced the ethernet chip just died, but 3 devices failing gradually over <48 hours suggests to me a staged firmware rollout.

Don’t know if I’m experiencing the same deal. Just installed an indoor wired camera at my daughters house, it did an update, and is now flaky, disconnecting after a minute or two, and it’s just 8 feet from the router. She has 4 ring devices outdoors and they’re all working perfectly. No amount of resets on this little indoor camera seems to get it connected for good. Maybe it’s the update?

I have 6 POE Elite cams that are all showing up with different ethernet MAC addresses now. This started on Nov. 28th through today. The camera seems to download the new update at the same time the IP address is renewed.

If either of you guys have NAC (Network Access Control) enabled on your router that requires you to explicitly register each device on the network - this could be the problem.


Maybe related but the MAC on my stickup camera definitely changed. The odd thing is that in the Ring app, the device still shows the original MAC address.

Hey neighbors. The MAC address for your Ring devices should not be changing like this. If your Camera is consistently falling offline or if you have a DHCP reservation, then you may need to utilize wifi or change your router security settings to allow the new MAC address via ethernet for the time being. In order to take a further look into this, can you please reach out to our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

Hi @Caitlyn_Ring ! Thanks for acknowledging the issue here and on Reddit!
I’m glad the rollout of buggy firmware version 11.0.24 has been suspended (at least from Ethernet devices). Do you happen to have an ETA for when a fixed firmware build will begin rolling out to impacted devices (Ethernet devices currently on 11.0.24)? Thanks!

Hi @dbeiter. Unfortunately we aren’t given an exact timeframe or ETA on future firmware releases or updates. My recommendation is to always keep your Ring app updated and just keep an eye out for any firmware updates to your devices. If I receive any information that I can share on this, I’ll update the associated threads. Thanks for your patience! :slight_smile:

1 Like

In the meantime, is there any way to downgrade the firmware to the previous version?

Hi @TPCNZ. I’m happy to chime in here. As of now, there is not a way for you to roll back the firmware to a previous version.

Hi @Justin_Ring ! I’m delighted to see a new firmware 11.0.33 was installed on one of my Ethernet-connected devices this week. If I want to update all my devices from the buggy 11.0.24 build to 11.0.33, is there anything a user can do to prompt their device to download the latest update? Or just wait for the staged rollout?

Bumping this thread. 1 month after the release of 11.0.33, one of my PoE devices picked it up, but the remainder are still on buggy 11.0.24. Any update on upgrading 11.0.24 devices to the fixed 11.0.33?

Hi @dbeiter. I don’t have an update to share at this time. Whenever my team lets me know that this has been resolved, and any firmware updates have been rolled out, I will share that information here in this thread.

1 Like

Chasing this same issue. Ring suspended the roll-out of 11.0.24, but now that there is a new version 11.0.33 the devices on 11.0.24 are not upgrading.
Rather than waiting to hear from the engineers, can you please specifically ask them why devices on the broken 11.0.24 are reporting firmware status “up to date” when they are not?
This issue is months old, please request some engineering escalation to fix it across the board.

Bumping this thread. @Justin_Ring @Caitlyn_Ring
I (and others) have devices offline for 5 months now…is there any update on the rollout of 11.0.33? I can bring the buggy devices online temporarily, but every time I try, they do not pick up the fixed firmware.

Woohoo! After five months of downtime, happy to report that my first 11.0.24 device was brought back online by new firmware 12.0.51


I just checked all three of my cameras and they’re all reporting 12.0.51 and they seem to be using the proper MAC address’s. Finally!!!

1 Like

Hey neighbors. Glad to hear that everything is as it should be!

Hi all, this issue started happening on my POE powered Sickup Cam Elite (Gen 2) device yesterday and continued through today (I’m UK based). I messed around and tried to get things to reconnect to no avail (tested other POE devices on the switch and all worked just fine, including my elite doorbell), then suddenly it started working again this evening - I checked the firmware via an integration (version no longer shows in the app?), and it’s at 12.0.51 - could it be that I just got hit with an update that knocked things out for me? Hoping things now hold out…

Nope, didn’t hold out for me, has dropped out twice since. :pensive:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.