New doorbell pro setup mode?

I’ve got a stick up camera which works well on my Android app & Echo.
Today I installed a doorbell pro, wired type with the supplied UK adapter.
It has powered up and now has a blue ring lit up with top left blinking. I have tried to enter setup mode pressing the button on the right side.
I have tried to hard reset pressing it for 30 seconds. After an initial white flash it just returns to the blinking blue again.
It’s brand new and I can’t connect to my network.
Is this a dud, or am I missing something ?

Hi there, @Butty! When first powering up the Video Doorbell Pro, I recommend letting it power on for several minutes to an hour. Then attempt a setup, in which the light indicator on your Video Doorbell Pro should blink for setup mode, and your Ring app should allow you to complete the setup steps. Please confirm if you are able to attempt setup in the Ring app, and that the Ring broadcasted wifi access point is broadcasting during setup. Feel free to let us know how this goes! :slight_smile:

Hi Marley,
Thanks for the reply. I tried again the next morning and it was the same.
I phoned Ring support & he talked me through the symptoms & reset etc. but still no good. He confirmed it was the internal battery still charging up (solid blue ring, top left blinking).
As he finished saying this it came alive and I got the spinning white ring. We completed the setup and the camera has been running for a week with no issues. Ring support were helpful.
If you’re reading this and you have the solid blue ring with top left blinking all you need to do is leave it powered up for at least an hour. I would leave it a bit longer than that to allow the internal battery to fully charge. It should come alive when it is ready.
Hope this helps.