New device not showing up in shared devices

I have just installed a wired camera and want to share it with my wife. However, the device is not showing up in the list. My other device is showing up.
Any thoughts what to do
Thanks Nico

I have the same issue. have not received a fix yet, but will post if I ever do get an answer.

Hey neighbors! The first best step is to ensure both apps are updated on both your own and the shared users’ mobile devices. Try also uninstalling and reinstalling the application to see if this improves functionality. If a device is still not allowing for a shared user to be added, please check to see if the camera in question is linked to other devices or part of a group of any sort in the app. I hope this helps! :slight_smile:

2 Likes

I have spent over 6+ hours with Ring tech support on this issue. And I went as far as sending multiple screenshots from mutile devices (iOS and Android) after many… many uninstalls… restarts and reinstalls… there was ONE guy that acknowledged the issue. But even then, nothing happened afterwards. Called back a week later, spent yet another half-hour with a lady that felt extremely dismissive only to learn that the “escalated” support ticket didn’t progress.

The support team could be more incompetent… and with their security breaches, adding two-factor authentication has made the sharing users a crucial feature. So only
If the owner account gets compromised there is a problem. Well, after months of NOTHING (literally nothing. The “case/issue” numbers have gotten me nowhere with RING), sharing tour main account is probably the ONLY workaround.

This is so crappy. I invested in quite a bit with these guys. And every time I call they just want to buy more time. Product is not getting better. And if you accept that it only works sometimes… then it’s ok.

I am looking at switching out to Nest. As soon as they get a spotlight, I am not accepting this nonsense.

2 Likes

I realized the previous post was just venting. Details of the simolarities of the issue.

Device is new. Works fine on my account. Doesn’t matter whose email I choose, remove then add back or which way I access the shared deviced screen, all

other devices show execept this one.

I tried adding yet another device (compact stickup cam) and it shows up fine as a sharable device.

Except for this one. Tried renaming, resetting. It seems to be something sbout this device. If I didn’t know any better, I’d say it’s a refurbished device that still belongs to another user somehow.

At any rate, Ring support was a waste of time. I am honestly looking at Nest. Unsure if Google is going to be much better when it comes to customer and device support, but it seems that Ring is definitely not getting better. So this is the price of admission.

Is anyone interested in buying some used Doorbell 2s?

3 Likes

Just bought a refurbed camera and am having the same issue - previous post may have hit on something, maybe this unit is installed on someone else’s account? It works fine on my account (master) but does not appear when sharing with wife or son (but doorbell cam does and that one was new in box)

Frustrating

I initially had this problem. In my case, it appears that the cause was the share invitation being sent to a different e-mail address than the e-mail address that I use for my Ring account. At first, I tried forwarding the invite e-mail to my Ring e-mail address, but that didn’t work. I then had my relative instead send a share invitation directly to my Ring e-mail address. It worked instantly.

I know how frustrating these problems can be. Hopefully the solution that worked for me will work for you. Good luck.

I had to remove my new device from the Light Group it was in for it to become available in the shared users screen. Tap on Device Settings | General Settings | Light Group and make sure “No Group Assigned” is selected. As soon as I did this, the Flood Light Cam was listed in Shared Users

4 Likes

OMG… that did it…

I simply removed the grouping from the device and it’s now sharable. This is definitely a bug. But this is an acceptable workaround.

3 Likes

This worked!!! Thank you ?

Removing from the light group worked. Thank you so very much.

1 Like

Thanks for the tip. Removing from light group worked for me. Sounds like yet another bug in the Ring system. Hope they have this logged somewhere and get it fixed soon so other users don’t encounter this.

I contacted customer support regarding the issue and they said they are aware of it and should have a fix soon. Another workaround I found was after you share it with lights groups turned off, you can then add back the light groups and it does not remove the shared users access. I tested this and it works. You won’t see the shared cameras if you go into shared users, but I can live with that for the meantime. If you need to remove access, you need to first remove the light group and then you can see the device in shared users.

I missed it at first because the ring guide to set up shared user doesnt state that after you set it up, to see the other person camera you need to change the location at the top of your dashboard view.
Ring peeps, please add this to the instructions. I received the shared user invite and went to my ring and couldn’t see their cam until i realized i had to change the location at the top of the dashboard veiw.

2 Likes

I had the same problem. Was previously sharing the Doorbell fine, but after adding a security camera could not get it to show up on the shared person’s account. Ultimately, I uninstalled the app on the other person’s phone. Then in my Account I went to Control Center, Shared Users, Manage. Then I removed the shared user. I then sent them another invitation to register with both Ring devices checked. Theoretically, this might’ve worked if I had just checked the camera (Doorbell was already checked) but I figured it was better to start from scratch. Then I re-installed the app & both devices were showing up. Hope that helps!

1 Like

I just had this issue on the app, but after about an hour of playing with the app I found the solution (at least for me). At the very top of the app (above the modes) in the middle there should be your Location with a drop down button (I have it saved as Home). If you click that drop down, it’ll show you all the locations on your account. If by chance you installed the new item under a new location, you’ll have to click on that location to see the camera. I unistalled the device, and reinstalled it using my same location (Home) and now I can see both my cameras without any issues.

1 Like

Just when we needed the remote access whilst away fora few days, to stickup cam it decided to go offline! The only way to re-instate it was to start over and give it a new name.

THEN although it showed my wife as a shared user her app wanted her to install the camera. Your solution to uninstall and reinstall the app on her tablet worked. Thanks!

What unnecessarily complex software.

I had the same problem where my new ring doorbell was not showing up.

To fix, I had to go in and delete the devices from my old location, and then delete that location. Once I deleted all of that, my new Ring 3 doorbell then appeared in my device list.

Definitely a bug that needs to be fixed.

Hubby is the owners of device.
He shared with me.
I log in using my email and password.
Cannot find a device.
App tells me to scan the QR code on the device or packaging to add a device
His phone also shows that I did NOT accept is invite.
What is wrong?
Thank you

Hi @Lizamichelle1. A few things to look at here. First, make sure you are on the correct Location. Sometimes, an additional location is inadvertently created when adding a shared used. If there are no “extra locations”, ask you husband to delete you as a Shared User, then add you again. Once this process is done, sign back into the Ring app and you should be able to see your devices. I hope this information helps!