New camera not showing up in Mode Settings

Hello, my first post, hope the community can help.

I’ve installed my system a few weeks ago, and it’s been working well so far. I’ve been able to change settings in Mode Settings, and as I installed a 7th camera today I tried to do this once again. My new camera does show up in Devices, but when I select my new camera it does not allow me to change the Mode Settings - of the 7 cameras only 5 show up. Have tried deinstalling & reinstalling, still don’t see it.

How can I get it to show up?



Hi there. I had exactly the same problem when adding the third camera after modes had been set up. I resolved it by completely exiting the app and then going back into to set up modes (flick app off in iOS and reopen).


I’m having literally the exact same issues. I’ve added a 7th camera to my location and no matter what I do, that camera does not show up while trying to adjust the settings of my “modes”. I’ve tried reinstalling the app. Resetting the camera, disabling modes and setting it back up again. The camera just will not show up as a selectable camera in the “modes” settings

Hi neighbors. I’ve passed this information onto my team so they can look into it and work on a resolution. In the meantime, please try completing a new setup of your Doorbell or Camera by following the prompts under Set Up a Device. As a reminder, only the owner of the Ring device can edit the Modes settings. If you’re still unable to edit the Mode settings, please follow up with our support team at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support. Thank you for your patience. :slight_smile:


I’m having the exact same issue. My new camera does not show up in “Mode Settings”.

Just set up my 4th indoor camera which doesn’t show up in “Mode Settings” too. I followed what roobos posted above for the IOS app and selected “Disable Mode Settings for Cameras” at the bottom of the page and reenabled it and the new camera showed up.

1 Like

Thanks for the advice. Tried that multiple times, but this doesn’t solve the issue. have even logged in from 4 different devices; no dice… :frowning:

Just felt with this, I had to disable modes and when I enabled them I had to select custom modes, cam showed up then

Just had the same problem. I previously had 3 cameras set up and working. Added 2 more cameras but they would not show up in Modes. Disabling and restarting Modes in the app did not work. Logged into my Ring account on the web, disabled, restarted, and all the cameras are there now.

1 Like

Had the same issue and resolved it by…Restarting Ring App on my phone. Then opened Ring app, Clicked settings, then click Modes. From here at the bottom is an option to Disable Modes. Click that…a warning pops up, click Disable Modes. Returned to Mode settings and all cameras showed up. For some reason when you add new cameras, they will not show up in your Mode settings. You will have to set up your Away and Home settings again.


You fixed my problem… Thank you


Disabling and re-enabling Modes fixed the issue: all newly installed cams appear in Modes after that.

Thanks for the work-around!

1 Like

Hi neighbors, our team is aware of this concern and are investigating. In the meantime, you can try disabling Modes and then re-enabling it to see if your newly added Ring device appears. You will have to adjust the Modes settings for all your devices again after doing this, but other neighbors in this thread have reported success with this workaround.

For now, I will mark this reply as the solution so that other neighbors can quickly see this information if they’re experiencing the same concern. Thank you for your patience in this matter. :slight_smile: