New battery, no blue light

We have several Ring doorbell cameras in our businesses, with the removable/rechargeable batteries. I have 1 that needed the battery changed, however, when I changed it, no light came on. Not the blue spinning light or the white spinning light when you press the reset button. I have tried several different batteries, so that isn’t the case. I plan on replacing the camera itself thinking that since its several years old it was at the end of its lifespan. Then this week, at another business location, I have a different and much newer camera (same generation)with the same issue. Is there a fix for this?

Hi @GTFO. If your Doorbell has a fully charged battery and it is unresponsive, try factory resetting it. To factory reset it, press and hold the setup button on it for 20–25 seconds. If you have tried this step and it is still unresponsive, give our support team a call for further assistance.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.