New alarm setup - Base will not connect to WIFI

I currently have a ring doorbell and received my Ring alarm system today. The base station refuses to connect to WIFI, but works via Ethernet. I have zero issues with other appliances connecting to WIFI, including my ring camera. It sees the SSID and my password is correct.

Any chance that it doesn’t like special characters in the password?

Any other ideas? I would appreciate any help.

It is not the special character in the router password causing the issue. I went through the pain of resetting the router (forgot the router admin password :face_with_symbols_over_mouth:) to remove the special char from the password.

Still no luck connecting to WiFi. So weird that the ring doorbell does not have an issue.

Hi @Ianrwilson. As a test, try connecting to a WiFi hotspot. If you can successfully connect to the hotspot, but are having issues with your home network, this usually means there are some security settings in place that your ISP will have to adjust. Let me know how this goes.

Thanks for the reply Tom. I ended up just leaving the base station upstairs next to my router, and plugged in via Ethernet. Not ideal but the extender seems to have things covered all the way to the basement.

Android was having issues adding primary doors, but I was able to get around this by using an iPhone instead.

I’ll give your suggestion a try when I am able, although it seems if this works via Ethernet then it is not the ISP, since the router and modem are mine.

Thanks
Ian

Hey @Ianrwilson. Great to hear that you have this solved for the time being. There still can be security settings on your wireless network, even though you were able to connect via ethernet. :slightly_smiling_face: