Neighbors Tile not in Ring Shortcuts & Neighbors App blank won't show settings

Hello,

Several months back my Neighbors App stopped working and only showed a blank white screen. Including the Control Center (Neighbors App). The Neighbors tile is also no longer showing in Ring shortcuts. I have called tech support (not helpful).

I have tried troubleshooting with the following:

  • Disabling and Re-enabling the Neighbors App in the Ring App Control Center
  • Force quitting, clearing cache and app data on BOTH Ring and Neighbors
  • Uninstalling and reinstalling BOTH Ring and Neighbors

I am at a total loss and it would be nice to be able to track local alerts and post videos to alert neighbors as I was once able to.

Tech and versions:
Pixel 6, Android 13, Build # TP1A.221005.002
Ring App v 3.54.0
Neighbors App v 3.68.1

Update: creating a new Neighbors login with my work email actually worked! But I still don’t understand why the email associated with my account doesn’t work with the Neighbors App

Hi @littleREDelf. I’m glad you were able to find a workaround for the Neighbors app loading a blank screen. Since you have tried the basic troubleshooting steps I would have suggested for your concern, you will have to contact our support team once more. Let the support team know this is an ongoing concern and they should be able to escalate you to our advanced support team for further assistance. Give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

omg, after 6 hours with tech support, i’m glad to read that i am not the only person with same exact problem. it has been a very rough 6 hours with tech support with little background support.

I too noticed that Neighbors just stopped working few months back after some software updates. this morning i captured an attempted burglary on video but couldn’t share it. i have reset passwords on both Ring and Neighbor apps. uninstalled, power cycled iphone, re-installed. i still got no feeds. i tested with neighbor app enabled and disabled, and on wifi and mobile cellular with no success. i installed neighbors on a separate device with same problem. i called and checked my internet company, all good. i was finally directed to email neighbors@cs.ring.com and am now waiting.

I also do not have to Community Neighbors item under my menu feed to configure my area. location services are on and i share with the app.

so grrrrrrrrrr