Neighbors feature

I have tried to enable the Neighbors feature on both Android phone and through the Web page. Both will allow me to enable and I receive a message that it saves the settings. Then when I check again, it shows the feature disabled.

Hi @porkradish1. I would make sure that you are running on the most current version of the Ring app. To ensure that it is optimally integrated, you can uninstall the Ring app, reboot your phone, then reinstall the Ring app. Also, make sure you that are not using a VPN. I hope this information helps!

I have this same problem. Followed the above instructions several times. The neighbors feature still does not work. Please fix. I have an iPhone11. Also tried logging in to and enabled the neighbors feature. Each time it reverts back to Disabled.

Hi @JC202. Since the above mentioned steps didn’t seem to help, I would contact our support team. They will be able to look into this for and provide you with the next best steps. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.