Neighbors App has wrong address

I’m starting a new post since the other post about this issue has been, incorrectly, marked as ‘Solved’. It isn’t!

I have my correct home address in my Ring App.

When I look at the address in the Neighbors App it shows a different address.

When I attempt to change the address in the Neighbors App it tells me to go change the address in the Ring App.

I do not want to change the addres in the Ring App since it is correct.

I want to change the incorrect address in the Neighbors App.

Why did you merge my post into this one, marked ‘solved’, when I specifically said it was not solved ?

Caitlyn_Ring (Community Manager) merged a reply in Ring App on 12-08-2020 07:03 AM:

Dec 2020 and having same issue… Spent a great deal of time on the phone with “tech support” to no avail. And now, reading others comments on this thread, it sounds like everyone is experiencing the same exact thing… And with no resolution, even years later. Great.

Same issue here. Tried all the listed solutions and nothing fixes it. The Neighbors app should be updated so we can specify an address independent of the one in our Ring app.

Still having the same issue. It won’t change for me or for other users I’ve allowed.

I tried fixing it for like an hour. Could not get it to work. At least I know it’s an issue an not just me.

Came here hoping there is an solution…sad to see this is not the case

I tried changing to an address that I previously lived, and it passed correctly to Neighbors App. And I tried changing it back to my current address, it does not work.

My current address is relatively new, about 2 years, I think their system is not up-to-date for address mapping.

Here is my workaround. My problem seems to be address too new (new construction) and Ring us different map data between two apps.

I found a nearby address that seems to be much older than mine and put it in the app and it sync across the apps. Its not ideal but at least the center of the Neighbors App is close to my home now.

I see that Ring still has not provided anyone with any useful feedback regarding this problem. If the address in the Ring App is correct, but your “neighborhood” geofence is in a completely different area…chances are you live in a fairly new development or the street name you live in is incorrect in the MapBox database (the maps Ring uses for some ungodly reason). Your best bet is to click on the mapbox logo on the bottom left of your map screen (in the neighborhood app) and submit an edit request if that’s the case. In my situation it’s both, I live on xxxxx Ln, but mapbox has it as xxxxx Ct. This puts my “neighborhood” about ten miles North of where I actually live, in the middle of nowhere. Hope this helps some of you!
That little red dot at the bottom is my actual home.

image|231x500

Pretty sad that this has been going on for well over a year now with no solution. I am having the same issue. When go to the wrong address it gives me a pop up that says To change it, open the side menu, select this location, then tap Settings, then Location. Problem is the location isn’t on the side menu anywhere. So makes it very difficult to do this. I also see no one from Ring has responded since October of 2019. Pretty sad state for them. Makes me wish I had bough one of the other options.

First Post-Been Lurking for a year. I have the same issue. My address is correct on the alarm side, and the correct radius shows on the app, but the zip code for the safety report is not the correct zip code. As a result all the weekly safety report is useless.

I was on with tech support for over 1 hour trying to resolve this-its very annoying. I had to turn on 2 factor authentication, delete the ring app and the rapid ring app and re install. DID NOT WORK.

Hoping for a resolution soon.