My shared user can’t see the connection

Hi, I have sent a share request for my mother in law for our security camera. She has set up her own account and received the email requesting her to join the shared location. When clicking on the share link it takes her to her shared manage in the control centre but it is blank. I have deleted the account and reset but still nothing. I did it for my wife and that worked fine but my mother in law’s account has no sign of the shared access request?

Thanks in advance


Hi @OwenP1601. I’d suggest verifying that you’ve shared access for the Camera under Settings > Users. Select your mother in law’s name and see if the Camera’s access has been toggled on. She will also need to ensure she is on the correct Location in the Ring app by going to the Ring app dashboard and selecting the Location name in the top center to bring up a drop-down menu. There should be an option with “(Shared)” in the title, and tapping this should bring her to the Location with the shared Camera.

I just solved this problem. Once you set up your new account from the email invite. Log into your account. I did this from a desktop computer. Go to control center>shared users and you should see your invite from the person who invited you. Click manage then accept.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.