My Ring Doorbell 2 doesn't ring anymore, but everything else works like video motion recording


I have no idea what happened, but within the past few days I just noticed that when you hit the doorbell button on my ring doorbell 2, the blue light no longer pops up spinning, and it doesn’t make a chime noise from it anymore. It’s as if hitting the button does nothing. I took off the plate and hit the button to ensure nothing was wrong with my plate, and I could even hear it clicking but nothing happens, no blue light.

I did a factory reset and re-added it to my app, still doesn’t ring.

The Live View works. The motion recording works. The doorbell functionality doesn’t work.

I checked battery health and its around 60% and said it was healthy.

I don’t get it? Any help?

You’ve done a great job to cover most troubleshooting steps @Tommy1005! The only additional step I would recommend than charging the Doorbell’s battery to 100%, and even power cycling the Doorbell 2 by removing the battery and reinserting it. Otherwise, it may be best to reach out to our support team for more in depth troubleshooting.

I bought my ring video 2 and 2 stick up cameras with 2 day delivery. The delivery came a week or more later. Now, after 3 or 4 calls with technical support my doorbell still isn’t working. Does anyone’s Ring products work?

I have a flood light can, 2nd Feb stick up cam, 3rd gen stickup cam, multiple inside cams, spotlights, path lights, motion sensor, chime, chime pro, Ring 2 doorbell and a total alarm system. Everything works great. But if you have a problem, I’d reach out to customer service.

Glad your stuff works. I have spent over an hour with 3 different support people

What trouble are you having? Maybe I can help

Mine does the same. No sound, and no lights. And now, it just makes a clicking noise and will not show live or record motion :frowning:

Hi @Kendiekw, happy to step in here. I would suggest performing a reset on your Doorbell after fully charging the battery. To reset it, simply hold down the setup button for at least 20 seconds. Once that’s done, try to walk through a new setup in the Ring App by following the steps under Set Up a Device. If your Doorbell is still not responding, please give our support team a call at one of the numbers available here. They can take a closer look at your device and provide more advanced troubleshooting steps. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

Posting for future people that find this thread and have the same problem.

I had to get a new Ring, luckily it was still under warranty.

No amount of resets or anything fixed it. New one worked fine and its worked since.

1 Like