My dashboard wont load, it just keeps spinning.

Hi, neighbors! Thank you for sharing your experience with the Community. The dashboard should certainly be loading as intended. As others have shared, removing and reinstalling the Ring app is a great first step. Please also ensure VPN is disabled, other apps are closed, and also test the difference between wifi connection and mobile data connection.

For any neighbor who have an android device, please check for any apps that might conflict with the Ring app.

If this concern persists despite trying the above steps, and only improves by altering shortcuts, please confirm what mobile device OS you are using. In the meantime, I will be sharing this feedback with our teams here for further investigation. :slight_smile:

This is not resolved! It continues and constantly occurs on a Pixel 4 running Android 11. The only remedy is to kill the app and restart it. This didn’t happen until the “Dashboard” was added!

@MdAl wrote:

So where is the solution. What is written here is clealy NOT A SOLUTION.I am havng this problem a lot.

Yup, the solution is to kill the app and reload, or select another option and come back to the Dashboard. I got the same problem too with a Pixel 2 on Android 11. I’ve had it now for maybe a month or so.

I’ve just gotten used to it, and curse “F…ing Ring” under my breathe as I close and reopen the app. Give it a try, it’ll make you feel better, at least it does for me.

Hey guys I don’t work for ring
so please don’t take it out on me. This is a Ring app BUG!!!
I can re-create the problem so please contact me.
I’m on a new AT&T note 20 ultra, latest software ect… If I hide the desktop shortcuts that I don’t have I can’t connect. If I unhide everything I can connect but have to force close the app after use for it to connect on next launch. Everyone having this problem knows it started after ring updated their app with these desktop shortcuts.
If anyone is having this problem please respond to this post so Ring can see this problem is not fixed.

This issue still persists (Android). It started at the beginning of the year. There are other post. It went away for a little while and was intermittent in the beginning. But now it happens every single time I try to access the Ring app. It doesn’t matter if I’m on Wi-Fi or 4G.
Now, there is no scenario under which the Ring dashboard won’t load.

Not only is this annoying, it can be stressful and problematic when you get a notification. But you can’t get to the history to see what’s going on to see if there’s actually a crime being committed. The tiles are not useful in that situation because you want to see the history to see which and how many cameras are being affected.

I, like others, have tried just about every permutation of troubleshooting. But it seems like with each app update, other things break or get worse. I’ve tried clearing the cache, installing uninstalling, etc. Calling the helpline about apps issues doesn’t work. The last time I called, the representative said it wasn’t his job. And when I asked him to switch me to a department that could help me, he said that there wasn’t one…

Are u working now after the last update?
I can no longer re-create the long dash board loading problem on Android 10

Are u working after the last update?
I no longer have the problem on Android 10

I am having the same problem! I have an IPhone 11. Help please

I started experiencing this exact problem 2 weeks ago. I have very strong wifi. I found that restarting the app on my iPhone 11 Pro solves the problem. But it’s frustrating to have to restart the app every time I want to lock/unlock my door(s).

It is now May and the problem still persist. I feel ripped off and tired of it. I keep getting This is taking longer than expected but it didn’t happen until last update. Prior to that I at least didnt get this. I have a Gigabyte network connection, mesh system with 3 towers 1 being right behind ring wall so it isn’t my internet. Please fix the darn thing we have waited long enough for a working product.

You are full of it it is NOT fixed mine is still doing it. It is now May and the problem still persist. I feel ripped off and tired of it. I keep getting This is taking longer than expected but it didn’t happen until last update. Prior to that I at least didnt get this. I have a Gigabyte network connection, mesh system with 3 towers 1 being right behind ring wall so it isn’t my internet. Please fix the darn thing we have waited long enough for a working product. Time for a class action suit

Same problem here with the app itself not loading. On Android, clearing storage does seem to help but it is ongoing.

I too am having this same problem on my iPhone 12. Although, selecting a specific option from the menu, and returning to the main/dashboard screen does NOT fix the issue, nor does force closing the App and re-opening. I cannot even get to the part to edit hidden dashboard shortcuts! This just started happening a few days ago. I have my Ring app linked to both my Amazon Key account as well as MyQ garage door. I think it has something to do with the Amazon Key link. I tried to remove the Key access point and re-add, which temporarily resolved the issue, until Key updated with an expected package delivery. Now the Dashboard just spins again! Clearly something is amiss with the Amazon Key link that never was an issue previously.

Update: I Unlinked both external accounts from the Ring app, and the Dashboard loads immediately! This doesn’t help, as I’d like to have those accounts linked back to Ring. Again, I’ve tried this already, and relinked, only to have the problem manifest again as soon as Key showed an expected package delivery for the day!

1 Like

I have the exact same issue. On both my iPhone and iPad Pro. Started happening about 2 days ago. I logged out of both devices and back in again and got the dashboard to load. Just now I got an Amazon key delivery notification about a new delivery being shipped. Once that happened, spinning dashboard again on both devices. I guess I will just need to remove the key delivery button from the dashboard to get it to load. It seems obvious it comes from the link to Key delivery. Worked fine for many weeks before this. Hopefully a new ring update will help.

I too have been experiencing this same issue. I had to unlink and then link my Amazon account to get the shortcut tiles to load on the dashboard. I am not expecting a delivery today so the Key Delivery tile shows nothing new. However if and when I do expect a delivery I hope it doesn’t cause the issue to happen again.

Same problem here on my iPhone 12. Dashboard works fine until I get a notification from Amazon for a new Key Delivery scheduled. After that, Dashboard won’t load. Get a spinning wheel and a message saying “This is taking longer than expected”. Running IOS 14.7. Since I get several Amazon Key Deliveries a week, this is a real pain.

Same issue,

iPhone 11 Pro Max, initially running 14.6

The issue is linked to the key delivery sign in. Only way I can get the dashboard to load is if uninstall and re-install, but as soon as I link the key delivery it will no longer load, and I cannot access the “Shortcuts” in settings.

I went into iPhone settings, and there is an update to 14.7 but it wasn’t pushed to my phone. Installing now and will see if it resolves the issue. I’ll reply once it’s fixed.

Ultra annoying issue.

@Tom_Ring or any Ring rep… can you “chime” in on this? Seems like a good idea to be active here to save time for both customers and your team… or we could all just continue to call?

So even after updating to iOS 14.7, the dashboard crashes when I sign into key delivery.

The myQ garage sign in works fine, but key delivery is what crashes it/prevents it from loading.

Hopefully we get a “hey we are working on it” reply soon

Hey neighbors! Thank you for the continued contribution in this thread. Our team is currently looking into this concern with the Dashboard not loading fully for the Ring app, specifically when Key deliveries are set up for said location. We will make sure to update you all accordingly when this is addressed and we appreciate your patience during this time.

Ditto exactly the same issue. I am looking forward to Caitlyn finding us a solution.