My dashboard wont load, it just keeps spinning.

Both my wife’s phone and mine are Android and they both did updates to the ring app and both are doing the same thing where the login screen just keep spinning. I also get a message that says “certificate validation failed! redirecting to login” I reinstalled the app and cleared the cash for the app. Nothing help.

Same with me. Two phones. Same exact trouble. Same time. Reinstalled to no avail. Please help.

Log in online on computer fine.

Hi neighbors, I’m sorry to hear you were unable to log into the Ring app. Rest assured, our team has investigated this and it looks like it should be resolved currently. You can always keep up to date on the status of Ring here: status.ring.com. Please let us know if there’s anything we can assist with in the meantime! :slight_smile:

What is the solution for that?

Hey @L4Rs1L. This issue has since been resolved and is not longer a concern. If you are having this error now, it could be due to the connection your phone has. Please try using mobile data instead of wifi, or vice versa to see if this helps the phone’s connection to your app! :slight_smile:

Was about to start a new post, but seen this. I just updated the app yesterday 9/24/2020, got version 3.30 0, and the Dashhboard just spins saying “This is taking longer than expected…” for about a minute everytime I open it.

Hi @RustyJones! This should not happen, especially with an updated Ring app. Although you just updated, please try removing and reinstalling the Ring app on your mobile device to ensure it is optimally integrated. I recommend also ensuring all other apps are closed in the background and vpn is disabled. If this concern persists, try testing the difference between wifi only connection and mobile data only connection, on your mobile device, to see if one is more efficient than the other. I hope this helps! :slight_smile:

Sorry, but it sounds like the app on my phone needs internet access to even display the buttons on the screen? But I did try disabling WIFI, and no change. Removed the app, reinstalled the app, no change. Still takes a while to load. It seems like I have to use something in the app, like settings, history, etc, then when I come back to the main screen, it will load. The older version worked better. I just got the history button, no dashboard that causes problems.

Hi @RustyJones. Jumping in for Marley! If you’ve tried the steps suggested to no avail, you might need our support team to help you investigate what the root cause of this could be. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.

It hasnt been resolved because mine is doing it and my signal and wifi are great device health great everything you can blame it on is working the trouble is your system is terrible! I cant rely on it to keep me safe and its a huge waste of money and i think there ought to be a lawsuit

2 Likes

I am having the same issue for the past week or so. Uninstalled App. Reinstalled. Charged the Ring Camera. Logged out and back in. Reinstalled the camera. Turned off wifi on the phone app and just going on data. Turned wifi back on!

Thought id give another update as its still happening. Un-installed the app, re-installed the app. Downloaded the next update for the app since there was a update since the last re-install. Still just spins. I have to go into the history from the drop down menu to access it the history. When I come back out of the history drop down menu, or another menu drop down, the Dashboard loads. If I never go into any menu, the dashboard never loads. I also tried this on my old phone, did a factory reset on the old phone, installed the app which had never been installed on that phone, it does the same thing.

1 Like

Exit non loading dashboard to live video then go back to dashboard it should load, then swipe the the shortcuts at the top of the dashboard to the left and choose “Edit”. Remove all hidden shortcuts and make ALL visible. Regardless if you don’t have the devices. Move the devices you do have to the top of the list. Close and open Ring app. It should load now

1 Like

That sort of works, the first time. If follow those instructions, and “force stop” the app in the settings, or swipe up on the Ring app to clear it, It works. If I don’t kill the app, or swipe up the app to clear it after I exit the app, it just spins every time I open it. Not sure what the app does different, compared to it opening the first time, like after a phone reboot or manually killing it. Compared to it running in the background all the time like it normally does. But that at least points to something that can be maybe troubleshooted further by Ring?

Yes you are correct the problem is with the Ring app. Making the dashboard shortcuts all visible seems to improve things but not completely fix the issue. I opened a ticket with Ring and hope they fix it soon. If I hide any shortcuts I get the spinning circle of doom. One more thing to try is go to settings, apps, Ring, storage, clear data. You won’t loose anything but you will have to log in again opening the Ring app. That also unhides your shortcuts. I know it gives you a warning about loosing everything but trust me you won’t. This at least makes the app usable until Ring Fixes this software bug.

So where is the solution. What is written here is clealy NOT A SOLUTION.I am havng this problem a lot.

1 Like

Same perpetual spinning issue here, every single time the app loads.

“Loading your dashboard…”

“This is taking longer than expected…”

As a previous poster mentioned, a workaround is to bring up the top left menu and go directly to History.

Nevertheless, this bug is untenable.

This is obviously low priority since I’ve been dealing with this issue for months with absolutely NO restitution from Ring or your Amazon owners. Hire some real software and server engineers that can resolve dumb issues like this. So far, the Ring experience is terrible since the app hangs because if this problem. It’s time to FIX IT!!!

Good find!

I would have the problem about 50% of the time starting Ring when only displaying the History icon. Adding back two hidden options makes it much more reliable. Hiding “Locks” seems to make it less stable than other options. Ring SHOULD be able to solve this problem with this information!

Ours has done the same thing for weeks (spinning wheel) …have reset, have reinstalled app, strong wifi & cellular… It’s a Ring software issue, not all the members fault