Multiple Indoor Cams won't complete setup - Ready to throw them out!

I’ve been trying to set up two indoor cams, neither will complete setup. Sometime it fails connecting to the wifi, sometimes it gives me a “device is registered to another owner”. I’m seriously ready to throw both of them in the trash. They worked fine up until a few days ago. The help articles are worthless, written for a total imbecile. I know how to check if it’s powered on, seriously? I also relocated the device to within a few feet of the wireless access point. I have multiple wireless zones with many devices attached, these are the only ones that don’t work. I’ve tried all different ways of completing the setup, it fails in different ways each time. So annoying, ready to switch to a whole other product line.

That makes two of us. Apparently device is registered to someone else even though it’s recently bought through Amazon

Hi neighbors! If you’re receiving messages that your Ring device is registered to another owner, I would highly urge you to contact our support team directly so they can look into this further and help get it sorted out. Please give our support team a call at one of the numbers available here. We’re taking additional steps to protect our team and help reduce the spread of COVID-19, so this has resulted in longer than normal wait times. If you are outside of the US, please read our response to COVID-19 here to see how to contact support.