Micro usb plug on the orange charging cord won't fit into the back of the ring video doorbell

The micro usb plug on the orange charging cord won’t fit into the back of the ring video doorbell. It has worked for a few years but now I have tried everything but it won’t go in all the way therefore its not charging.


This is happening to mine too. Very strange. What did you do? I’m past the warranty and looks like I can’t charge it anymore. It’s the port that won’t accept the plug anymore. Not is damaged, it’s more like the portal closed up half way in.

The included micro USB should always fit the charging port on your Video Doorbell or battery. If it is not inserting at all, please check for debris or obstructions in the port. It is also a great step to ensure the USB is not damaged.

Our support team can also help further with this. Please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

I have the same issue. Nothing is blocking the port and it’s the cord that came with the device. It doesn’t go in all the way so I can’t charge it. This doesn’t make sense as worked and charged many times before. At first I thought it was the wrong cord but it’s the same. Nothing is damaged, it simply doesn’t fit anymore. What options are there other than to toss it?

Have the same problem as the rest of you. I see ya all got a run-around answer. Did any of yoju find a answer??

I’m having the same problem with the USB port. Anyone found a solution?

I believe this is a Scam to get you to purchase new Ring product. There is no debris and absolutely no reason why this stopped working all of a sudden. It’s like the device was developed with this “shutdown to prevent charge” feature! Our other technology freely receives plug-ins for life. This is suspect/a scam with a bogus explanation/so-called help from Ring! What makes them think that we’d buy another Ring product! I won’t!!!

1 Like

I don’t believe anyone is lying except ring. There are too many of us experiencing the same issue. Please come up with a plausible solution to this problem. It is not the cable and it is not debris and it is not operator error.

Hi @user17419. If your charging cable no longer fits into your Ring Doorbell or battery, it’s possible there is some damage to either the cable itself or to the charging port. If you have another micro USB cable available, try using that to see if it works. If not, then it’s possible the charging port itself is damaged and the best course of action would be to follow up with our support team.

Hi. I realize this is an old post, but in case anyone out there is doing a google search on this topic, I wanted to add my experience.

Mine is one of those 1st gen Ring doorbells that cannot be hardwired and relies solely on battery. Have had it for about 4 years and the usb socket issue started after less than a year.

There is definitely nothing wrong with the cord and there is no debris inside. It just seems like it won’t plug in all the way. It almost feels like the device came with the wrong cable or something.

But I’ve discovered that if I “play with it” for a while I can eventually get it to start charging. It is extremely frustrating because it can take anywhere from 10 minutes to repeated tries over a period of hours for it to finally work. Using a different cord makes no difference, and I’ve never found any “trick” to speed the process along. It’s just a matter of perserverence, unfortunately.

I should note that once that blue light finally starts spinning to indicate it is charging, I have to be very careful not to bump or twist the cord even a tiny bit when I set it down, or it is back to square one. I actually always set mine on top of a tall pint glass so it is closer to the outlet and so I can clearly see the spinning blue light, which does periodically need to be checked to make sure it is still charging.

Anyway, I thought if there’s someone out there getting ready to throw theirs in the trash, they may want to try fiddling with it a bit first. The rigamarole is seriously aggravating, but better than throwing money away or going without, I guess.

Same problem here, I have the first gen ring and the orange cord that it came with does not properly plug in any more. I jiggled it around and plugged back in and out a few times and it finally worked. I also tried different micro-USB cords to see if that would help. The other cord I tried plugged in all the way but it still did not charge, so I went back to the orange one. This sure does seem like a known defect with this product and Ring should fix it for free. Given that most smart phones can be plugged in every day for 3-5 years you would think that the Ring can handle plugging it in 2-3x per year for 4 years… Do the math, that’s 1000+ times through the life of your phone that you use the connector on the phone to charge with no issues, yet the Ring, after 4 years of using the connector maybe 20 times fails???

Hey neighbors. Just to reaffirm what Marley has previously mentioned, there should be no difficulty when you insert your micro USB charger into your Ring Device. If you are having difficulty charging your device, you can try a different USB cable or purchase a new one here. If you are still having this problem, please give our support team a call at one of the numbers available here. If you are outside of the US, please visit here to see how to contact support.

1 Like

I’m having the same problem charging. Did anyone get the replacement USB kit and see if it works? My USB recharging cord is fine and seems unlikely it would work….

I have purchased FOUR ring battery doorbells and ALL FOUR quit taking a charge and have this charging problem. All quit within a year and are now beyond warranty. Will Ring pay to fix this clear product defect???

I’ve had the same problem with the TWO Ring doorbells I’ve owned. They are unable to fit the charger after about the year and are useless. It’s so frustrating that this is clearly a Ring defect. My second one just started having the problem. I’m ready to leave Ring and try a new video doorbell brand. It’s ridiculous!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.