Message from Ring that "You camera has been deactivated"

I got an email message this morning from Ring that my “Security Camera has been deactivated”.
We are confirming that you successfully deactivated your Security Camera in your Ring account. You will no longer be able to control this device or change its settings.

I checked in the App and it also says that one of my cameras is “deactivated”.

I’ve had “device offine” alerts in the App before, but never a “deactivation”. My doorbell and two other camera’s are working fine.

Has anyone else seen this behavoir recently? I called Ring support , but it was a pretty brutal call center experience, and in no way helpful.

I will try to reset the device this afternoon, but I’m more curious how this would happen in the first place.

same thing happened to me to this morning. i have three other cameras up and running, except this one. I have no idea how or why it was deactivated. Hoping someone else answers so I can figure it out.

1 Like

Hi neighbors. It sounds like your devices have been disconnected from wifi, although I know seeing that a device has been “deactivated” would cause some concern. When you’re able to, please try reconnecting your Camera to your wifi network following the steps here. If those steps don’t work, you can also try a new setup using the steps under Set Up a Device.

If you’re unable to get your device reconnected using the steps above, please follow up with our support team for further assistance. If you are outside of the US, please visit here to see how to contact support.

Me too. Found out this morning that one of the cameras that I had was deactivated. Got a txt message around 3:30 with a verification cod. I wonder if some has or tried to hack my Ring account. Now I know I’m not the only one this has happened to.

To get it working again. I ended up removing the camera from my Ring account on their website and adding it back in thru the Ring app on my phone.


Exactly what happened to me. Call to CS was no help at all. If this requires physical access to the device, I will have to haul out an extension ladder and climb up to the top. BUT I’m 68 yo and don’t do ladders anymore so that’s not an option. Ring caused this, Ring should fix it. Camera has been up less than 60 days, and if it isn’t fixed TODAY it’s going back to Amazon for a refund. Not worth the hassle. This device seems more like a toy than a security solution.

Our hardwired floodlight deactivated today. Received an email confirming it was deactivated. Called Support, they do not show any reason for the problem but if I want to wait days for their team to investigate, they will. Otherwise, I can reactivate it only by going through the whole new device process again (meaning getting on a ladder to scan and redoing all settings again).

How is this acceptable? There should be no possible way that devices can simply deactivate themselves. And how come Ring can’t just reactivate the darn thing? Very unimpressed with this company.

I have the exact same problem. Climbing to the top of an extension ladder to reach the device is NOT something I can do anymore. Ring CS does not know why it happened, and cannot offer any solution that doesn’t involve physical access to reset the device which, again, I just can’t do at my age. Instead, I would rather get someone to remove it, then return it and get a refund (been up less than 60 days), so I can get something more reliable from a competitor. I’m really uncomfortable with any security device that just gets randomly deactivated.

I bought a Ring indoor camera a month ago for a remote property that I am at a few months a year. It worked fine for several weeks and then I left. A few days after leaving, I got an email from Ring saying that my camera was deactivated. I did not request this and apparently this happens frequently. The only way to reactivate it is to be physically on site to scan the code as was done to start with. This is not an option since the camera is a 3 hour airplane ride away and I have no one at that location that can do this. After spending much time on the phone with Ring and realizing this has been happening for many years and often, I am disappointed that Ring has not taken some action so that they do not deactivate cameras without a customer request and also that they have not developed a method to reactivate the cameras. My only solution is to spend a day and about $500 to fly to this location to reactivate the camera. Ring will not give any type of refund and does not grasp that this can be a serious security issue and that I relied on them. Very disappointed in Ring!

My camera is DEAD no power…I tried using my other functioning ring power adapter and NOTHING. It’s completely dead. I also received the email saying it was deactivated. All my other cameras are fine! Has anyone figured this out?

Hi @LizzieGA78. With adequate power, you should be able to perform a reset by holding down the setup button for 20 seconds. After that, take the Camera through a new setup in the Ring app using the steps under Set Up a Device.

If your Camera is unresponsive despite receiving sufficient power, you would need to contact our support team for assistance. The Ring Community is a public forum, so we aren’t able to view device details. You can give our support team a call at one of the numbers available here.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.